aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-ZConf-Mail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/p5-ZConf-Mail/Makefile')
-rw-r--r--mail/p5-ZConf-Mail/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/mail/p5-ZConf-Mail/Makefile b/mail/p5-ZConf-Mail/Makefile
new file mode 100644
index 000000000000..bdf53917d044
--- /dev/null
+++ b/mail/p5-ZConf-Mail/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-ZConf-Mail
+# Date created: 2009-01-14
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ZConf-Mail
+PORTVERSION= 0.0.0
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Misc mail client functions backed by ZConf
+
+RUN_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/ZConf.pm:${PORTSDIR}/net/p5-ZConf \
+ ${SITE_PERL}/Email/Simple/Creator.pm:${PORTSDIR}/mail/p5-Email-Simple-Creator \
+ ${SITE_PERL}/Mail/IMAPTalk.pm:${PORTSDIR}/mail/p5-Mail-IMAPTalk \
+ ${SITE_PERL}/Mail/IMAPTalk.pm:${PORTSDIR}/mail/p5-Mail-IMAPTalk \
+ ${SITE_PERL}/Mail/POP3Client.pm:${PORTSDIR}/mail/p5-Mail-POP3Client \
+ ${SITE_PERL}/Net/SMTP_auth.pm:${PORTSDIR}/mail/p5-Net-SMTP_auth \
+ ${SITE_PERL}/Net/SMTP/TLS.pm:${PORTSDIR}/mail/p5-Net-SMTP-TLS \
+ ${SITE_PERL}/Mail/Box.pm:${PORTSDIR}/mail/p5-Mail-Box \
+ ${SITE_PERL}/Curses/UI.pm:${PORTSDIR}/devel/p5-Curses-UI \
+ ${SITE_PERL}/IO/MultiPipe.pm:${PORTSDIR}/devel/p5-IO-MultiPipe
+
+PERL_CONFIGURE= yes
+
+MAN3= ZConf::Mail.3
+
+.include <bsd.port.mk>