aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix22/scripts/configure.postfix
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix22/scripts/configure.postfix')
-rw-r--r--mail/postfix22/scripts/configure.postfix7
1 files changed, 6 insertions, 1 deletions
diff --git a/mail/postfix22/scripts/configure.postfix b/mail/postfix22/scripts/configure.postfix
index 40200db72cdc..9c4efcf4f411 100644
--- a/mail/postfix22/scripts/configure.postfix
+++ b/mail/postfix22/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.68 2005-11-30 19:25:11 mnag Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.69 2005-11-30 22:25:35 mnag Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -24,6 +24,7 @@ SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" "$status_SASL" \
SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" "$status_SASL2" \
SASLKRB "If your SASL requires Kerberos select this option" "$status_SASLKRB" \
SASLKRB5 "If your SASL requires Kerberos5 select this option" "$status_SASLKRB5" \
+SASLKRB5MIT "If your SASL requires MIT Kerberos5 select this option" "$status_SASLKRB5MIT" \
SPF "SPF support" "$status_SPF" \
TLS "SSL and TLS" "$status_TLS" \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" "$status_DB3" \
@@ -101,6 +102,10 @@ while [ "$1" ]; do
SASLKRB5)
echo "POSTFIX_AUXLIBS+= -lkrb5 -lcrypto -lcrypt -lcom_err -lasn1 -lroken"
;;
+ SASLKRB5MIT)
+ echo "LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5"
+ echo "POSTFIX_AUXLIBS+= -Wl,--rpath,\$\${KRB5_HOME:-${LOCALBASE}}/lib -lkrb5 -lcrypto -lcrypt -lcom_err"
+ ;;
SPF)
# see http://www.ipnet6.org/postfix/spf/
echo "LIB_DEPENDS+= spf2.1:\${PORTSDIR}/mail/libspf2-10"