aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird-esr
diff options
context:
space:
mode:
Diffstat (limited to 'mail/thunderbird-esr')
-rw-r--r--mail/thunderbird-esr/Makefile1
-rw-r--r--mail/thunderbird-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
2 files changed, 18 insertions, 0 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 7afad8bd8a46..f4b5a113c490 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}
diff --git a/mail/thunderbird-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/mail/thunderbird-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/mail/thunderbird-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }