aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/thunderbird/Makefile')
-rw-r--r--mail/thunderbird/Makefile45
1 files changed, 31 insertions, 14 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 800b0113dccc..798821f4b873 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -2,26 +2,30 @@
# $FreeBSD$
PORTNAME= thunderbird
-DISTVERSION= 17.0.8
+DISTVERSION= 24.0
CATEGORIES= mail ipv6
-MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source
-DISTFILES= ${PORTNAME}-${DISTVERSION}esr.source${EXTRACT_SUFX}
-EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}esr.source${EXTRACT_SUFX}
+MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source
+DISTFILES= ${PORTNAME}-${DISTVERSION}.source${EXTRACT_SUFX}
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
COMMENT= Mozilla Thunderbird is standalone mail and news that stands above
-BUILD_DEPENDS= nspr>=4.9.2:${PORTSDIR}/devel/nspr \
- nss>=3.13.6_1:${PORTSDIR}/security/nss \
- sqlite3>=3.7.13:${PORTSDIR}/databases/sqlite3 \
+BUILD_DEPENDS= nspr>=4.10:${PORTSDIR}/devel/nspr \
+ nss>=3.15:${PORTSDIR}/security/nss \
+ sqlite3>=3.7.16.1:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
cairo>=1.10.2_1,1:${PORTSDIR}/graphics/cairo \
+ v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
unzip:${PORTSDIR}/archivers/unzip
+LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-EM_VERSION= 1.5.1
+EM_VERSION= 1.5.2
+L_VERSION= 2.6b3
USE_AUTOTOOLS= autoconf213:env
USE_PYTHON_BUILD=-2.7
+OBJDIR_BUILD= # in-tree build broken after bug 789837
USE_GECKO= gecko
USE_MOZILLA= # empty
@@ -29,10 +33,9 @@ WANT_GNOME= yes
USE_QT4= # empty
QT_NONSTANDARD= yes
ALL_TARGET= default
-GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= gmake pkgconfig
USE_GL= gl
+USE_DOS2UNIX= mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
MOZ_PROTOCOLS= http,ftp,file,viewsource,res,data,wyciwyg,websocket
MOZ_OPTIONS= --program-transform-name='s/thunderbird/${MOZILLA}/' \
@@ -51,19 +54,30 @@ MOZ_PIS_SCRIPTS=moz_pis_S50cleanhome
OPTIONS_DEFINE= ENIGMAIL LIGHTNING
OPTIONS_DEFAULT=ENIGMAIL LIGHTNING
+# non-client.mk objdir build broken after bug 846540
+.undef GNU_CONFIGURE
+ALL_TARGET= build
+MAKEFILE= ${WRKSRC}/client.mk
+
.include "${.CURDIR}/../../www/firefox/Makefile.options"
-OPTIONS_DEFAULT:=${OPTIONS_DEFAULT:S/ALSA/OSS/}
+# OSS is gone after bug 852401
+OPTIONS_SINGLE_AUDIO:=${OPTIONS_SINGLE_AUDIO:S/OSS//}
.include <bsd.port.pre.mk>
-WRKSRC= ${WRKDIR}/comm-esr17
+WRKSRC= ${WRKDIR}/comm-esr24
MOZSRC:= ${WRKSRC}/mozilla
XPI_LIBDIR= ${PREFIX}/lib/xpi
+# libprldap60.so: Undefined symbol "PR_GetCurrentThread"
+.if ${ARCH} == i386
+USE_GCC?= yes
+.endif
+
.if ${PORT_OPTIONS:MENIGMAIL}
-MASTER_SITES+= http://www.enigmail.net/download/source/:enigmail
+MASTER_SITES+= https://www.enigmail.net/download/source/:enigmail
DISTFILES+= ${EM_DISTFILE}:enigmail
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
EM_DISTNAME= enigmail-${EM_VERSION}
@@ -75,13 +89,14 @@ EM_ID_RFILES= ${XPI_LIBDIR}/${EM_ID}/install.rdf \
${XPI_LIBDIR}/${EM_ID}/components/enigmail.js \
${XPI_LIBDIR}/${EM_ID}/modules/enigmailCommon.jsm
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-enigmail-ipc-src-Makefile
+EXTRA_PATCHES+= ${FILESDIR}/extra-bug886095
.endif
.if ${PORT_OPTIONS:MLIGHTNING}
MOZ_OPTIONS+= --enable-calendar
MOZ_MK_OPTIONS+= MOZ_CO_PROJECT=calendar
LIGHTNING_DIR= share/lightning
-XPI_FILE= ${MOZ_OBJDIR}/mozilla/dist/xpi-stage/lightning.xpi
+XPI_FILE= ${MOZ_OBJDIR}/mozilla/dist/xpi-stage/lightning-${L_VERSION}.en-US.${OPSYS:L}${OSREL}-${ARCH:S/amd64/x86_64/}.xpi
XPI_ORIG_ID= {e2fda1a4-762b-4020-b5ad-a41df1933103}
XPI_ID= lightning@thunderbird.mozilla.org
.else
@@ -97,6 +112,8 @@ post-extract:
.endif
post-patch:
+ @${REINPLACE_CMD} -e '/MOZPNG/s/=[0-9]*/=10511/' \
+ ${MOZSRC}/configure.in ${WRKSRC}/configure.in
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/mail/app/nsMailApp.cpp
.if ${PORT_OPTIONS:MENIGMAIL}