aboutsummaryrefslogtreecommitdiff
path: root/mail/ximian-connector/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/ximian-connector/Makefile')
-rw-r--r--mail/ximian-connector/Makefile36
1 files changed, 27 insertions, 9 deletions
diff --git a/mail/ximian-connector/Makefile b/mail/ximian-connector/Makefile
index 1756b804bc9d..5ab39285bf6c 100644
--- a/mail/ximian-connector/Makefile
+++ b/mail/ximian-connector/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= ximian
-PORTVERSION= 1.4.7.1
-PORTREVISION= 1
+PORTVERSION= 2.0.2
CATEGORIES= mail gnome
-MASTER_SITES= http://ftp.ximian.com/pub/source/evolution/
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}${PKGNAMESUFFIX}/2.0
PKGNAMESUFFIX= -connector
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
@@ -19,18 +19,36 @@ COMMENT= Evolution plugin to connect to Microsoft Exchange servers
BUILD_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
RUN_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+USE_BZIP2= yes
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
USE_GMAKE= yes
-WANT_OPENLDAP_VER= 21
-WANT_OPENLDAP_SASL= yes
+USE_OPENLDAP= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnometarget
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -rpath ${X11BASE}/lib/evolution/${EVO_VERSION}"
CONFIGURE_ARGS= --with-openldap=${LOCALBASE} \
--with-static-ldap=no
-EVO_VERSION= 1.4
-PLIST_SUB= VERSION="1.4" EVO_VERSION=${EVO_VERSION}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+EVO_VERSION= 2.0
+PLIST_SUB= VERSION="2.0" EVO_VERSION=${EVO_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000 && defined(MAKE_KERBEROS5) && \
+ exists(/usr/lib/libkrb5.so) && !defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --with-krb5=/usr
+.elif ( ${OSVERSION} < 500000 && !defined(MAKE_KERBEROS5) ) || \
+ defined(PACKAGE_BUILDING)
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
+CONFIGURE_ARGS+= --with-krb5=${LOCALBASE}
+.elif ${OSVERSION} >= 500000 && !defined(NO_KERBEROS) && \
+ exists(/usr/lib/libkrb5.so)
+CONFIGURE_ARGS+= --with-krb5=/usr
+.else
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
+CONFIGURE_ARGS+= --with-krb5=${LOCALBASE}
+.endif
+
+.include <bsd.port.post.mk>