aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/relaydb/Makefile23
-rw-r--r--mail/relaydb/distinfo1
-rw-r--r--mail/relaydb/pkg-descr8
-rw-r--r--mail/relaydb/pkg-plist1
5 files changed, 34 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index b0e863fbf263..29bd8fbcc5d1 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -269,6 +269,7 @@
SUBDIR += rbl-milter
SUBDIR += rblcheck
SUBDIR += regm
+ SUBDIR += relaydb
SUBDIR += rftp
SUBDIR += ricochet
SUBDIR += ripmime
diff --git a/mail/relaydb/Makefile b/mail/relaydb/Makefile
new file mode 100644
index 000000000000..8ecaa9467855
--- /dev/null
+++ b/mail/relaydb/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: relaydb
+# Date created: 10 August 2003
+# Whom: Matt Jibson <dolmant@dolmant.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= relaydb
+PORTVERSION= 1.3
+CATEGORIES= mail
+MASTER_SITES= http://www.benzedrine.cx/
+
+MAINTAINER= dolmant@dolmant.net
+COMMENT= Spam relay database
+
+MAN8= relaydb.8
+MANCOMPRESSED= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/relaydb ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/relaydb.8.gz ${PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/mail/relaydb/distinfo b/mail/relaydb/distinfo
new file mode 100644
index 000000000000..1bab42304a03
--- /dev/null
+++ b/mail/relaydb/distinfo
@@ -0,0 +1 @@
+MD5 (relaydb-1.3.tar.gz) = 360536437837bb2a67d356282a1a03b0
diff --git a/mail/relaydb/pkg-descr b/mail/relaydb/pkg-descr
new file mode 100644
index 000000000000..06c6c9bf82f2
--- /dev/null
+++ b/mail/relaydb/pkg-descr
@@ -0,0 +1,8 @@
+relaydb is a mail header analyzer that builds a database of IP addresses either
+known as legitimate senders or spammers.
+
+relaydb doesn't itself classify mails as legitimate or spam, that decision needs
+to be reached through other means. Neither does relaydb block spam itself. It
+merely provides a list of IP addresses to block through other means.
+
+WWW: http://www.benzedrine.cx/relaydb.html
diff --git a/mail/relaydb/pkg-plist b/mail/relaydb/pkg-plist
new file mode 100644
index 000000000000..b1f368bb5efb
--- /dev/null
+++ b/mail/relaydb/pkg-plist
@@ -0,0 +1 @@
+bin/relaydb