aboutsummaryrefslogtreecommitdiff
path: root/math/fityk
diff options
context:
space:
mode:
Diffstat (limited to 'math/fityk')
-rw-r--r--math/fityk/Makefile6
-rw-r--r--math/fityk/files/patch-src__guess.cpp12
-rw-r--r--math/fityk/files/patch-src__wxgui__sidebar.cpp11
3 files changed, 27 insertions, 2 deletions
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 451b81c605cf..2eb288fe283e 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fityk
PORTVERSION= 0.9.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MASTER_SITES= GHC SF/xylib:xylib
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:DEFAULT \
@@ -19,11 +19,13 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/spirit/include/classic_core.hpp:${PORT
gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-USES= desktop-file-utils gmake libtool shared-mime-info tar:bzip2
+USES= compiler:c++11-lib desktop-file-utils gmake libtool \
+ shared-mime-info tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
LDFLAGS+= -lbz2 -lz
USE_GITHUB= yes
GH_ACCOUNT= wojdyr
+USE_CXXSTD= c++11
USE_GNOME= gtk20
USE_WX= 3.0
WX_CONF_ARGS= absolute
diff --git a/math/fityk/files/patch-src__guess.cpp b/math/fityk/files/patch-src__guess.cpp
new file mode 100644
index 000000000000..b71ae44c0bba
--- /dev/null
+++ b/math/fityk/files/patch-src__guess.cpp
@@ -0,0 +1,12 @@
+--- src/guess.cpp.orig 2011-06-04 00:10:02 UTC
++++ src/guess.cpp
+@@ -15,7 +15,8 @@
+ #include "settings.h"
+
+ using namespace std;
+-using boost::array;
++// Macro to avoid ambiguity with std::array (C++11)
++#define array boost::array
+
+ const array<string, 3> Guess::linear_traits =
+ {{ "slope", "intercept", "avgy" }};
diff --git a/math/fityk/files/patch-src__wxgui__sidebar.cpp b/math/fityk/files/patch-src__wxgui__sidebar.cpp
new file mode 100644
index 000000000000..d123d102cd62
--- /dev/null
+++ b/math/fityk/files/patch-src__wxgui__sidebar.cpp
@@ -0,0 +1,11 @@
+--- src/wxgui/sidebar.cpp.orig 2015-04-30 21:04:15 UTC
++++ src/wxgui/sidebar.cpp
+@@ -897,7 +897,7 @@ void SideBar::update_func_inf()
+ realt a;
+ if (func->get_center(&a))
+ inf->AppendText(wxT("Center: ")
+- + s2wx(format1<realt, 30>("%.10"REALT_LENGTH_MOD"g", a)));
++ + s2wx(format1<realt, 30>("%.10" REALT_LENGTH_MOD "g", a)));
+ if (func->get_area(&a))
+ inf->AppendText(wxT("\nArea: ") + s2wx(S(a)));
+ if (func->get_height(&a))