aboutsummaryrefslogtreecommitdiff
path: root/math/fxt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/fxt/Makefile')
-rw-r--r--math/fxt/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index ab821e469cdf..a65a21b141cc 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -15,7 +15,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USES= gmake
MAKEFILE= makefile
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
@${REINPLACE_CMD} -E \
@@ -26,14 +26,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|sinl|sin|g' ${WRKSRC}/src/fht/hartleyshift.h
post-install:
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/00*.txt ${STAGEDIR}${DOCSDIR}/
-.endif
-.if !defined(NOPORTEXAMPLES)
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/demo && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}/)
-.endif
plist:
@truncate -s0 pkg-plist
@@ -68,4 +64,4 @@ plist:
's,^${DOCSDIR}(.*),%%PORTDOCS%%@dirrm %%DOCSDIR%%\1,' \
>> pkg-plist
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>