aboutsummaryrefslogtreecommitdiff
path: root/math/gretl/files/patch-lib::Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'math/gretl/files/patch-lib::Makefile.in')
-rw-r--r--math/gretl/files/patch-lib::Makefile.in21
1 files changed, 6 insertions, 15 deletions
diff --git a/math/gretl/files/patch-lib::Makefile.in b/math/gretl/files/patch-lib::Makefile.in
index b96b6985645c..a58f01ed37ba 100644
--- a/math/gretl/files/patch-lib::Makefile.in
+++ b/math/gretl/files/patch-lib::Makefile.in
@@ -1,6 +1,6 @@
---- lib/Makefile.in.orig 2009-12-31 01:22:21.000000000 +0900
-+++ lib/Makefile.in 2010-02-02 03:11:21.000000000 +0900
-@@ -34,6 +34,10 @@
+--- lib/Makefile.in.orig 2010-11-17 08:55:23.000000000 -0500
++++ lib/Makefile.in 2011-02-02 15:59:26.000000000 -0500
+@@ -38,6 +38,10 @@
RPATH = $(DARWIN_RPATH)
endif
@@ -11,9 +11,9 @@
ifeq ($(INSTALL_PROGRAM),)
INSTALL_PROGRAM = $(INSTALL) -m 755
endif
-@@ -56,14 +60,14 @@
+@@ -59,14 +63,14 @@
+
# Installation directories
- libdir = $(prefix)/lib
includedir = $(prefix)/include/gretl
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
@@ -29,7 +29,7 @@
#### End of system configuration section. ####
-@@ -232,10 +236,10 @@
+@@ -238,10 +242,10 @@
LOBJS = $(SRCS:.c=.lo)
AUX_LOBJ = $(CEPHES_SRC:.c=.lo) $(MINPACK_SRC:.c=.lo)
@@ -42,12 +42,3 @@
COMPILE = $(LIBTOOL) --mode=compile $(CCV) -c $(CFLAGS)
-@@ -246,7 +250,7 @@
-
- $(LIBGRETL): .deps $(LOBJS) $(AUX_LOBJ)
- $(LDECHO)
-- $(AMP)$(LIBTOOL) --mode=link $(CCV) -o $@ $(LOBJS) $(AUX_LOBJ) \
-+ $(AMP)$(LIBTOOL) --mode=link $(CCV) $(LDFLAGS) -o $@ $(LOBJS) $(AUX_LOBJ) \
- -rpath $(RPATH) $(LIBS) -version-info $(CURRENT):$(REVISION):$(AGE)
-
- .deps: