aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 90bbdf3fd02c..a529759007cf 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,6 +3,7 @@
PORTNAME= octave
PORTVERSION= 3.8.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= octave
@@ -32,7 +33,8 @@ LIB_DEPENDS= libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick13 \
libqrupdate.so:${PORTSDIR}/math/qrupdate \
libumfpack.so:${PORTSDIR}/math/suitesparse \
libglpk.so:${PORTSDIR}/math/glpk \
- libgl2ps.so:${PORTSDIR}/print/gl2ps
+ libgl2ps.so:${PORTSDIR}/print/gl2ps \
+ qscintilla2:${PORTSDIR}/devel/qscintilla2
USES= charsetfix fortran gmake libtool perl5 pkgconfig tar:bzip2
USE_PERL5= build
@@ -40,7 +42,7 @@ USE_TEX= dvipsk:build
GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.7+
-USE_QT4= gui network
+USE_QT4= gui network uic_build moc_build rcc_build linguist_build
OCTAVE_VERSION= ${PORTVERSION}
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}