aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-SymbolicX-Complex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/p5-Math-SymbolicX-Complex/Makefile')
-rw-r--r--math/p5-Math-SymbolicX-Complex/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/p5-Math-SymbolicX-Complex/Makefile b/math/p5-Math-SymbolicX-Complex/Makefile
new file mode 100644
index 000000000000..3fbe5c371b66
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-SymbolicX-Complex
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-Complex
+PORTVERSION= 0.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Complex number support for the Math::Symbolic parser
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::Complex.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>