aboutsummaryrefslogtreecommitdiff
path: root/math/prng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/prng/Makefile')
-rw-r--r--math/prng/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/math/prng/Makefile b/math/prng/Makefile
index 43d25e158d0c..f6ddeb68933b 100644
--- a/math/prng/Makefile
+++ b/math/prng/Makefile
@@ -13,28 +13,29 @@ LICENSE= GPLv2
CFLAGS+= -fgnu89-inline
GNU_CONFIGURE= yes
-INFO= prng
+INFO= prng
PLIST_FILES= include/prng.h lib/libprng.a
PORTDOCS= prng.dvi prng.pdf prng.ps prng.txt
PORTEXAMPLES= Makefile pairs.c tuples.c
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for _d in ${PORTDOCS}
- ${INSTALL_MAN} ${WRKSRC}/doc/${_d} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${_d} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for _e in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/examples/${_e} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${_e} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.endif
check regression-test test: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} check)
.include <bsd.port.mk>