aboutsummaryrefslogtreecommitdiff
path: root/math/qtiplot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/qtiplot/Makefile')
-rw-r--r--math/qtiplot/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 8090e0081113..01b528b41f04 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= libgsl.so:math/gsl \
# qwt.5:x11-toolkits/qwt5 \
# qwtplot3d-qt4:math/qwtplot3d-qt4
-USES= dos2unix gmake qmake tar:bzip2
-USE_QT4= gui opengl svg qt3support network assistantclient \
+USES= dos2unix gmake qmake qt:4 tar:bzip2
+USE_QT= gui opengl svg qt3support network assistantclient \
moc_build rcc_build
USE_GL= glu
QMAKE_ARGS+= LOCALBASE=${LOCALBASE} PYTHON_CMD=${PYTHON_CMD}
@@ -34,7 +34,8 @@ OPTIONS_SUB= yes
DOCS_DESC= Install the QtiPlot Handbook
DOCS_RUN_DEPENDS= qtiplot-doc>=0:math/qtiplot-doc
-DOCS_USE= QT4=assistant-adp_run
+DOCS_USES= qt:4
+DOCS_USE= QT=assistant-adp_run
PYTHON_DESC= Python scripting support
PYTHON_USES= pyqt:4 python:2.7
@@ -42,7 +43,8 @@ PYTHON_USE= pyqt=gui
PYTHON_CONFIGURE_ENV= PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR} \
PYTHON_VERSION=${PYTHON_VERSION}
-NLS_USE= QT4=linguisttools_build
+NLS_USES= qt:4
+NLS_USE= QT=linguisttools_build
post-extract:
${CP} ${FILESDIR}/build.conf ${WRKSRC}