aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse/files/patch-UFconfig+UFconfig.mk
diff options
context:
space:
mode:
Diffstat (limited to 'math/suitesparse/files/patch-UFconfig+UFconfig.mk')
-rw-r--r--math/suitesparse/files/patch-UFconfig+UFconfig.mk49
1 files changed, 30 insertions, 19 deletions
diff --git a/math/suitesparse/files/patch-UFconfig+UFconfig.mk b/math/suitesparse/files/patch-UFconfig+UFconfig.mk
index d0ff8ab143de..b6d2a3f6376b 100644
--- a/math/suitesparse/files/patch-UFconfig+UFconfig.mk
+++ b/math/suitesparse/files/patch-UFconfig+UFconfig.mk
@@ -1,6 +1,6 @@
---- UFconfig/UFconfig.mk.orig Wed Dec 13 03:52:47 2006
-+++ UFconfig/UFconfig.mk Sat Feb 10 21:45:50 2007
-@@ -31,8 +31,8 @@
+--- UFconfig/UFconfig.mk.orig 2007-10-24 22:55:44.000000000 +0900
++++ UFconfig/UFconfig.mk 2008-02-03 12:04:00.000000000 +0900
+@@ -32,8 +32,8 @@
# C compiler and compiler flags: These will normally not give you optimal
# performance. You should select the optimization parameters that are best
# for your system. On Linux, use "CFLAGS = -O3 -fexceptions" for example.
@@ -11,7 +11,7 @@
# ranlib, and ar, for generating libraries
RANLIB = ranlib
-@@ -43,8 +43,9 @@
+@@ -44,8 +44,9 @@
MV = mv -f
# Fortran compiler (not normally required)
@@ -23,29 +23,29 @@
F77LIB =
# C and Fortran libraries
-@@ -73,8 +74,8 @@
- # These settings will probably not work, since there is no fixed convention for
- # naming the BLAS and LAPACK library (*.a or *.so) files. Assume the Goto
- # BLAS are available.
--BLAS = -lgoto -lgfortran -lgfortranbegin
+@@ -85,8 +86,8 @@
+ # BLAS = -lgoto -lgfortran -lgfortranbegin
+
+ # This is probably slow ... it might connect to the Standard Reference BLAS:
+-BLAS = -lblas -lgfortran -lgfortranbegin
-LAPACK = -llapack
+BLAS = %%BLAS%%
+LAPACK = %%LAPACK%%
# The BLAS might not contain xerbla, an error-handling routine for LAPACK and
# the BLAS. Also, the standard xerbla requires the Fortran I/O library, and
-@@ -102,8 +103,8 @@
+@@ -114,8 +115,8 @@
# The path is relative to where it is used, in CHOLMOD/Lib, CHOLMOD/MATLAB, etc.
# You may wish to use an absolute path. METIS is optional. Compile
# CHOLMOD with -DNPARTITION if you do not wish to use METIS.
-METIS_PATH = ../../metis-4.0
-METIS = ../../metis-4.0/libmetis.a
-+METIS_PATH = %%LOCALBASE%%/include/metis
-+METIS = %%LOCALBASE%%/lib/libmetis.a
++METIS_PATH = %%METIS_PATH%%
++METIS = %%METIS%%
# If you use CHOLMOD_CONFIG = -DNPARTITION then you must use the following
# options:
-@@ -126,7 +127,7 @@
+@@ -138,7 +139,7 @@
# -DNRECIPROCAL do not multiply by the reciprocal
# -DNO_DIVIDE_BY_ZERO do not divide by zero
@@ -54,21 +54,32 @@
#------------------------------------------------------------------------------
# CHOLMOD configuration
-@@ -176,12 +177,12 @@
+@@ -177,7 +177,7 @@
+ # -DNSUNPERF for Solaris only. If defined, do not use the Sun
+ # Performance Library
+
+-CHOLMOD_CONFIG =
++CHOLMOD_CONFIG = %%CHOLMOD_CONFIG%%
+
+ #------------------------------------------------------------------------------
+ # Linux
+@@ -184,15 +185,15 @@
+
+ # Using default compilers:
+ # CC = gcc
+-CFLAGS = -O3
++# CFLAGS = -O3
# alternatives:
# CFLAGS = -g -fexceptions \
- -Wall -W -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
- -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
+# -Wall -W -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
-+# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
++# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
# CFLAGS = -O3 -fexceptions \
- -Wall -W -Werror -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
- -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
--CFLAGS = -O3 -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
+# -Wall -W -Werror -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
+# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
-+# CFLAGS = -O3 -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
+ # CFLAGS = -O3 -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
# CFLAGS = -O3
-
- # consider: