aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Statistics-Distributions/Makefile23
-rw-r--r--math/p5-Statistics-Distributions/distinfo1
-rw-r--r--math/p5-Statistics-Distributions/pkg-comment1
-rw-r--r--math/p5-Statistics-Distributions/pkg-descr10
-rw-r--r--math/p5-Statistics-Distributions/pkg-plist8
6 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index f97b292ab202..7f4417351cf3 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -60,6 +60,7 @@
SUBDIR += p5-Set-IntSpan
SUBDIR += p5-Statistics-ChiSquare
SUBDIR += p5-Statistics-Descriptive
+ SUBDIR += p5-Statistics-Distributions
SUBDIR += pari
SUBDIR += parmetis
SUBDIR += physcalc
diff --git a/math/p5-Statistics-Distributions/Makefile b/math/p5-Statistics-Distributions/Makefile
new file mode 100644
index 000000000000..65a522b96263
--- /dev/null
+++ b/math/p5-Statistics-Distributions/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: math/p5-Statistics-Distributions
+# Date created: 01 January 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-Distributions
+PORTVERSION= 0.05
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::Distributions.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-Distributions/distinfo b/math/p5-Statistics-Distributions/distinfo
new file mode 100644
index 000000000000..15a3fef5b7ae
--- /dev/null
+++ b/math/p5-Statistics-Distributions/distinfo
@@ -0,0 +1 @@
+MD5 (Statistics-Distributions-0.05.tar.gz) = 7a34f2f62ef246bc145270b53552da0e
diff --git a/math/p5-Statistics-Distributions/pkg-comment b/math/p5-Statistics-Distributions/pkg-comment
new file mode 100644
index 000000000000..d70c1a23a0c3
--- /dev/null
+++ b/math/p5-Statistics-Distributions/pkg-comment
@@ -0,0 +1 @@
+Perl module that calculates critical values of common statistical distributions
diff --git a/math/p5-Statistics-Distributions/pkg-descr b/math/p5-Statistics-Distributions/pkg-descr
new file mode 100644
index 000000000000..beeddd22ab84
--- /dev/null
+++ b/math/p5-Statistics-Distributions/pkg-descr
@@ -0,0 +1,10 @@
+This Perl module calulates percentage points (5 significant digits) of
+the u (standard normal) distribution, the student's t distribution, the
+chi-square distribution and the F distribution. It can also calculate
+the upper probability (5 significant digits) of the u (standard normal),
+the chi-square, the t and the F distribution. These critical values are
+needed to perform statistical tests, like the u test, the t test, the F
+test and the chi-squared test, and to calculate confidence intervals.
+
+-Anton
+<tobez@tobez.org>
diff --git a/math/p5-Statistics-Distributions/pkg-plist b/math/p5-Statistics-Distributions/pkg-plist
new file mode 100644
index 000000000000..c5f0b0662017
--- /dev/null
+++ b/math/p5-Statistics-Distributions/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/auto/Statistics/Distributions/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Statistics/Distributions/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Statistics/Distributions.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Statistics/Distributions
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Statistics/Distributions
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Statistics 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Statistics 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Statistics 2>/dev/null || true