aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/algae/Makefile2
-rw-r--r--math/armadillo/Makefile2
-rw-r--r--math/clp/Makefile2
-rw-r--r--math/gap/Makefile2
-rw-r--r--math/gotoblas/Makefile2
-rw-r--r--math/libR/Makefile2
-rw-r--r--math/libRmath/Makefile2
-rw-r--r--math/math77/Makefile2
-rw-r--r--math/openfst/Makefile2
-rw-r--r--math/openlibm/Makefile2
-rw-r--r--math/trlan/Makefile2
-rw-r--r--math/vowpal_wabbit/Makefile1
-rw-r--r--math/z3/Makefile2
13 files changed, 25 insertions, 0 deletions
diff --git a/math/algae/Makefile b/math/algae/Makefile
index 441743691920..deb2194ac784 100644
--- a/math/algae/Makefile
+++ b/math/algae/Makefile
@@ -13,6 +13,8 @@ COMMENT= Programming language for numerical analysis
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= Does not build
+
BROKEN_ia64= does not compile
BROKEN_powerpc= does not compile
BROKEN_sparc64= does not compile
diff --git a/math/armadillo/Makefile b/math/armadillo/Makefile
index c9b729d8401f..30254b2e1b41 100644
--- a/math/armadillo/Makefile
+++ b/math/armadillo/Makefile
@@ -11,6 +11,8 @@ COMMENT= C++ linear algebra library
LICENSE= MPL
+BROKEN_powerpc64= Does not build
+
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libarpack.so:math/arpack \
libhdf5.so:science/hdf5 \
diff --git a/math/clp/Makefile b/math/clp/Makefile
index cf84655b9210..7278ec840517 100644
--- a/math/clp/Makefile
+++ b/math/clp/Makefile
@@ -12,6 +12,8 @@ COMMENT= Linear Programming Solver
LICENSE= EPL
+BROKEN_powerpc64= Does not build
+
USES= blaslapack fortran libtool tar:tgz pathfix
CXXFLAGS+= -ffast-math
diff --git a/math/gap/Makefile b/math/gap/Makefile
index 45e2180dc7a5..df3de17ca956 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -12,6 +12,8 @@ DISTNAME= ${GAP_VERSION}p${PORTVERSION:R:E}_${GAP_DISTTIME}
MAINTAINER= johans@FreeBSD.org
COMMENT= GAP is a system for computational discrete algebra
+BROKEN_powerpc64= Does not build
+
LIB_DEPENDS= libgmp.so:math/gmp
USES= gmake shebangfix tar:bzip2
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index 444966cdb287..d3f21324aaab 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -19,6 +19,8 @@ COMMENT= Fast implementation of Basic Linear Algebra Subprograms
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/00License.txt
+BROKEN_powerpc64= Does not build
+
GOTOBLAS2VER= 1.13
GOTOBLAS2_SRCFILE= GotoBLAS2-${GOTOBLAS2VER}_bsd.tar.gz
LAPACKVER= 3.4.0
diff --git a/math/libR/Makefile b/math/libR/Makefile
index 2a40c2733516..fa1433641cef 100644
--- a/math/libR/Makefile
+++ b/math/libR/Makefile
@@ -11,4 +11,6 @@ MASTERDIR= ${.CURDIR}/../R
PLIST= ${.CURDIR}/pkg-plist
PLIST_FILES= lib/R/lib/libR.a
+BROKEN_powerpc64= Does not build
+
.include "${MASTERDIR}/Makefile"
diff --git a/math/libRmath/Makefile b/math/libRmath/Makefile
index 1df8c5aab029..58bb25cf4625 100644
--- a/math/libRmath/Makefile
+++ b/math/libRmath/Makefile
@@ -10,4 +10,6 @@ LIBRMATH_SLAVEPORT= yes
MASTERDIR= ${.CURDIR}/../R
PLIST= ${.CURDIR}/pkg-plist
+BROKEN_powerpc64= Does not build
+
.include "${MASTERDIR}/Makefile"
diff --git a/math/math77/Makefile b/math/math77/Makefile
index 2098a4ad95d7..eddae890bf11 100644
--- a/math/math77/Makefile
+++ b/math/math77/Makefile
@@ -12,6 +12,8 @@ COMMENT= CalTech mathematical subprogram libraries for Fortran 77
LICENSE= BSD3CLAUSE
+BROKEN_powerpc64= Does not build
+
USES= fortran gmake tar:tgz
WRKSRC= ${WRKDIR}/MATH77
MAKEFILE= makefile
diff --git a/math/openfst/Makefile b/math/openfst/Makefile
index 9c226f790d38..49e1c36aabb8 100644
--- a/math/openfst/Makefile
+++ b/math/openfst/Makefile
@@ -11,6 +11,8 @@ COMMENT= Library for working with weighted finite-state transducers (FSTs)
LICENSE= APACHE20
+BROKEN_powerpc64= Does not build
+
USES= compiler:c++11-lib libtool
USE_LDCONFIG= ${LOCALBASE}/lib/fst
GNU_CONFIGURE= yes
diff --git a/math/openlibm/Makefile b/math/openlibm/Makefile
index a439ebf51a70..d41d3f7cd9b7 100644
--- a/math/openlibm/Makefile
+++ b/math/openlibm/Makefile
@@ -14,6 +14,8 @@ LICENSE= MIT ISCL BSD2CLAUSE
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+BROKEN_powerpc64= Does not build
+
USE_GITHUB= yes
GH_ACCOUNT= JuliaLang
GH_PROJECT= openlibm
diff --git a/math/trlan/Makefile b/math/trlan/Makefile
index 39c02fabb601..d094f4ff708b 100644
--- a/math/trlan/Makefile
+++ b/math/trlan/Makefile
@@ -14,6 +14,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= bf@FreeBSD.org
COMMENT= Thick-restart Lanczos method for eigenproblems
+BROKEN_powerpc64= Does not build
+
USES= fortran
USE_LDCONFIG= yes
diff --git a/math/vowpal_wabbit/Makefile b/math/vowpal_wabbit/Makefile
index 10563e6f51d8..df9de5d39fe9 100644
--- a/math/vowpal_wabbit/Makefile
+++ b/math/vowpal_wabbit/Makefile
@@ -11,6 +11,7 @@ COMMENT= Fast out-of-core learning system
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
BROKEN_FreeBSD_9= does not build
+BROKEN_powerpc64= Does not build
USES= compiler:c++11-lang libtool
GNU_CONFIGURE= yes
diff --git a/math/z3/Makefile b/math/z3/Makefile
index 273645320707..cc156bcf535d 100644
--- a/math/z3/Makefile
+++ b/math/z3/Makefile
@@ -11,6 +11,8 @@ COMMENT= Z3 Theorem Prover
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_powerpc64= Does not build
+
USE_GITHUB= yes
GH_ACCOUNT= Z3Prover