aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/scilab-toolbox-sivp/Makefile24
-rw-r--r--math/scilab-toolbox-sivp/files/patch-r28731
-rw-r--r--math/scilab-toolbox-sivp/pkg-descr4
-rw-r--r--math/scilab-toolbox-sivp/pkg-message5
4 files changed, 50 insertions, 14 deletions
diff --git a/math/scilab-toolbox-sivp/Makefile b/math/scilab-toolbox-sivp/Makefile
index 0a5d916ed14a..434fcd8aa666 100644
--- a/math/scilab-toolbox-sivp/Makefile
+++ b/math/scilab-toolbox-sivp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sivp
DISTVERSION= 1.0.0.r286
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math graphics multimedia
MASTER_SITES= LOCAL/makc
PKGNAMEPREFIX= scilab-toolbox-
@@ -15,9 +15,14 @@ LIB_DEPENDS= libopencv_legacy.so:${PORTSDIR}/graphics/opencv
RUN_DEPENDS= ${SCILAB_CMD}:${PORTSDIR}/math/scilab
USES= dos2unix pkgconfig tar:xz
-DOS2UNIX_FILES= etc/SIVP.start
+DOS2UNIX_FILES= etc/SIVP.start \
+ sci_gateway/cpp/builder_gateway_cpp.sce \
+ sci_gateway/cpp/sivp_init.cpp
+
+SCILAB_CMD= ${LOCALBASE}/bin/scilab-adv-cli
+SCILAB_ARGS= -noatomsautoload -nb -nouserstartup
+MAKE_ENV= LC_ALL="C" SCI_JAVA_ENABLE_HEADLESS=1 SCI_DISABLE_TK=1
-SCILAB_CMD= ${LOCALBASE}/bin/scilab
CONTRIBDIR?= share/scilab/contrib
TOOLBOXDIR_REL?= ${CONTRIBDIR}/${PORTNAME}
TOOLBOXDIR= ${PREFIX}/${TOOLBOXDIR_REL}
@@ -25,26 +30,21 @@ PLIST_SUB= TOOLBOXDIR=${TOOLBOXDIR_REL}
TOOLBOX_SUBDIRS= demos etc images macros
OPTIONS_DEFINE= HELP
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+OPTIONS_DEFAULT= HELP
+OPTIONS_SUB= yes
HELP_DESC= Build help files (requires scilab with gui support)
.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MHELP}
-SCILAB_ARGS= -nogui
-PLIST_SUB+= HELP="@comment "
+SCILAB_ARGS+= -nwni
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-etc__SIVP.start
.else
-USES+= display:build
-MAKE_ENV= LC_ALL="C"
-PLIST_SUB+= HELP=""
TOOLBOX_SUBDIRS+= jar
.endif
pre-everything::
- @${ECHO_CMD}
- @${ECHO_CMD} "If you want video support, OpenCV should be compiled with ffmpeg!"
- @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
post-patch:
.if !${PORT_OPTIONS:MHELP}
diff --git a/math/scilab-toolbox-sivp/files/patch-r287 b/math/scilab-toolbox-sivp/files/patch-r287
new file mode 100644
index 000000000000..599bbdf6fbf8
--- /dev/null
+++ b/math/scilab-toolbox-sivp/files/patch-r287
@@ -0,0 +1,31 @@
+Index: sci_gateway/cpp/builder_gateway_cpp.sce
+===================================================================
+--- sci_gateway/cpp/builder_gateway_cpp.sce (revision 286)
++++ sci_gateway/cpp/builder_gateway_cpp.sce (revision 287)
+@@ -120,7 +120,8 @@
+ opencv_libs = [];
+ end
+
+-
++ inter_cflags = inter_cflags + ' -D__USE_DEPRECATED_STACK_FUNCTIONS__';
++
+ tbx_build_gateway('gw_sivp', ..
+ gw_cpp_table, ..
+ gw_cpp_files, ..
+Index: sci_gateway/cpp/sivp_init.cpp
+===================================================================
+--- sci_gateway/cpp/sivp_init.cpp (revision 286)
++++ sci_gateway/cpp/sivp_init.cpp (revision 287)
+@@ -18,11 +18,11 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ ***********************************************************************/
+ /*--------------------------------------------------------------------------*/
+-#include "api_scilab.h"
+ #include "localization.h"
+ #include "Scierror.h"
+ #include "common.h"
+ #include "gw_sivp.h"
++#include "api_scilab.h"
+ /*--------------------------------------------------------------------------*/
+ char sSIVP_PATH[MAX_FILENAME_LENGTH];
+ /*--------------------------------------------------------------------------*/
diff --git a/math/scilab-toolbox-sivp/pkg-descr b/math/scilab-toolbox-sivp/pkg-descr
index 7c45a28be97b..62c5034a9ef3 100644
--- a/math/scilab-toolbox-sivp/pkg-descr
+++ b/math/scilab-toolbox-sivp/pkg-descr
@@ -3,5 +3,5 @@ intends to do image processing and video processing tasks. SIVP is
meant to be a useful, efficient, and free image and video processing
toolbox for Scilab.
-WWW: http://sivp.sourceforge.net/
-WWW: http://atoms.scilab.org/toolboxes/SIVP
+WWW: http://sivp.sourceforge.net/
+WWW: http://atoms.scilab.org/toolboxes/SIVP
diff --git a/math/scilab-toolbox-sivp/pkg-message b/math/scilab-toolbox-sivp/pkg-message
new file mode 100644
index 000000000000..acbd8f53605c
--- /dev/null
+++ b/math/scilab-toolbox-sivp/pkg-message
@@ -0,0 +1,5 @@
+=========================================================================
+
+ For video support graphics/opencv must be compiled with ffmpeg option.
+
+=========================================================================