aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-fraction/Makefile21
-rw-r--r--math/py-fraction/distinfo3
-rw-r--r--math/py-fraction/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bb9be988b65b..bc05d30a78af 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -834,6 +834,7 @@
SUBDIR += py-fastdtw
SUBDIR += py-flax
SUBDIR += py-fpylll
+ SUBDIR += py-fraction
SUBDIR += py-fvcore
SUBDIR += py-gau2grid
SUBDIR += py-gimmik
diff --git a/math/py-fraction/Makefile b/math/py-fraction/Makefile
new file mode 100644
index 000000000000..b27fa51eed15
--- /dev/null
+++ b/math/py-fraction/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= fraction
+PORTVERSION= 2.1.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Fraction-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Carry out all the fraction operations
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-fraction/distinfo b/math/py-fraction/distinfo
new file mode 100644
index 000000000000..cb164375817b
--- /dev/null
+++ b/math/py-fraction/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647264406
+SHA256 (Fraction-2.1.1.tar.gz) = 75a27c61c68f357dbb8ea395eab932b3a16a3aa2b6aa44a052bcef319724f882
+SIZE (Fraction-2.1.1.tar.gz) = 4568
diff --git a/math/py-fraction/pkg-descr b/math/py-fraction/pkg-descr
new file mode 100644
index 000000000000..f7cc9ec4e0e8
--- /dev/null
+++ b/math/py-fraction/pkg-descr
@@ -0,0 +1,4 @@
+fraction is a Python module that is designed for fractional values
+numerator/denominator.
+
+WWW: https://github.com/bradley101/fraction