aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/pecl-big_int/Makefile4
-rw-r--r--math/pecl-bitset/Makefile4
-rw-r--r--math/pecl-bitset2/Makefile4
-rw-r--r--math/pecl-stats/Makefile4
-rw-r--r--math/pecl-trader/Makefile3
-rw-r--r--math/rkward-kde4/Makefile4
6 files changed, 6 insertions, 17 deletions
diff --git a/math/pecl-big_int/Makefile b/math/pecl-big_int/Makefile
index 505e45bd0f5a..64ef8989c5a4 100644
--- a/math/pecl-big_int/Makefile
+++ b/math/pecl-big_int/Makefile
@@ -11,9 +11,7 @@ DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= Functions for calculations with arbitrary length integers and bitsets
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
DOCS= CREDITS INSTALL LICENSE README docs/index.html libbig_int/CREDITS \
diff --git a/math/pecl-bitset/Makefile b/math/pecl-bitset/Makefile
index 33aee6226d25..276400bb4533 100644
--- a/math/pecl-bitset/Makefile
+++ b/math/pecl-bitset/Makefile
@@ -15,8 +15,6 @@ LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
IGNORE_WITH_PHP=55 56
-USE_PHP= yes
-USE_PHPEXT= yes
-USES= tar:tgz
+USES= php:ext tar:tgz
.include <bsd.port.mk>
diff --git a/math/pecl-bitset2/Makefile b/math/pecl-bitset2/Makefile
index 52b3cd1e7118..3b3917873e3f 100644
--- a/math/pecl-bitset2/Makefile
+++ b/math/pecl-bitset2/Makefile
@@ -18,8 +18,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PORTSCOUT= limit:^2\.
IGNORE_WITH_PHP=70
-USE_PHP= yes
-USE_PHPEXT= yes
-USES= tar:tgz
+USES= php:ext tar:tgz
.include <bsd.port.mk>
diff --git a/math/pecl-stats/Makefile b/math/pecl-stats/Makefile
index 0b753e3d4b26..e7ea635c299d 100644
--- a/math/pecl-stats/Makefile
+++ b/math/pecl-stats/Makefile
@@ -13,9 +13,7 @@ COMMENT= PECL extension which with routines for statistical computation
LICENSE= PHP30
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/math/pecl-trader/Makefile b/math/pecl-trader/Makefile
index 6c42c39d1c8f..40d970716f66 100644
--- a/math/pecl-trader/Makefile
+++ b/math/pecl-trader/Makefile
@@ -14,8 +14,7 @@ COMMENT= Trader extension based on TA-Lib
LICENSE= BSD2CLAUSE
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/math/rkward-kde4/Makefile b/math/rkward-kde4/Makefile
index 518b64de7a5b..f8d38649811f 100644
--- a/math/rkward-kde4/Makefile
+++ b/math/rkward-kde4/Makefile
@@ -21,9 +21,7 @@ USE_QT4= corelib dbus gui qmake_build moc_build network phonon rcc_build \
script svg uic_build webkit xml
USE_XORG= x11
USE_KDE4= automoc4 kdelibs
-USE_PHP= yes
-WANT_PHP_CLI= yes
-USES= cmake gettext fortran shared-mime-info
+USES= cmake gettext fortran php:cli shared-mime-info
INSTALLS_ICONS= yes
CFLAGS+= -I${LOCALBASE}/include