aboutsummaryrefslogtreecommitdiff
path: root/mbone/rat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mbone/rat/Makefile')
-rw-r--r--mbone/rat/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/mbone/rat/Makefile b/mbone/rat/Makefile
index 746885541023..cd715a63ddc4 100644
--- a/mbone/rat/Makefile
+++ b/mbone/rat/Makefile
@@ -7,7 +7,6 @@
PORTNAME= rat
PORTVERSION= 4.2.13
-
PORTREVISION= 0
CATEGORIES= mbone audio ipv6
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/4.2.13/ \
@@ -23,8 +22,6 @@ USE_GMAKE= yes
MAN1= rat.1
MANCOMPRESSED= no
-PATCH_DEBUG= yes
-
RAT_BUILD_DIRS= common rat
.include <bsd.port.pre.mk>
@@ -42,12 +39,12 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/rat/sdr2.plugin.S02.audio.rtp.*.rat ${LOCALBASE}/etc/sdr/plugins
do-build:
- for d in ${RAT_BUILD_DIRS}; do \
- cd ${WRKSRC}/$$d && ${GMAKE}; \
- done
+.for d in ${RAT_BUILD_DIRS}
+ cd ${WRKSRC}/${d} && ${GMAKE}
+.endfor
do-configure:
- cd ${WRKSRC}/common && autoconf && ./configure ${ENABLE_IPv6}
- cd ${WRKSRC}/rat && autoconf && ./configure --with-tcl=${LOCALBASE} --with-tk=${LOCALBASE} ${ENABLE_IPv6}
+ cd ${WRKSRC}/common && autoconf && ./configure ${CONFIGURE_ARGS} ${ENABLE_IPv6}
+ cd ${WRKSRC}/rat && autoconf && ./configure ${CONFIGURE_ARGS} --with-tcl=${LOCALBASE} --with-tk=${LOCALBASE} ${ENABLE_IPv6}
.include "bsd.port.post.mk"