aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
Diffstat (limited to 'mbone')
-rw-r--r--mbone/imm/Makefile18
-rw-r--r--mbone/imm/distinfo1
-rw-r--r--mbone/imm/files/patch-aa195
-rw-r--r--mbone/imm/files/patch-ab19
-rw-r--r--mbone/imm/pkg-comment1
-rw-r--r--mbone/imm/pkg-descr5
-rw-r--r--mbone/imm/pkg-plist3
-rw-r--r--mbone/vic/Makefile25
-rw-r--r--mbone/vic/distinfo1
-rw-r--r--mbone/vic/files/patch-aa45
-rw-r--r--mbone/vic/files/patch-ab38
-rw-r--r--mbone/vic/files/patch-ac24
-rw-r--r--mbone/vic/pkg-comment1
-rw-r--r--mbone/vic/pkg-descr5
-rw-r--r--mbone/vic/pkg-plist4
15 files changed, 0 insertions, 385 deletions
diff --git a/mbone/imm/Makefile b/mbone/imm/Makefile
deleted file mode 100644
index 4787ecf45947..000000000000
--- a/mbone/imm/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-# New ports collection makefile for: imm
-# Version required: 3.3
-# Date created: 13 October 1994
-# Whom: wollman
-#
-# $Id: Makefile,v 1.4 1995/04/01 12:48:03 jkh Exp $
-#
-
-DISTNAME= imm-3.3
-CATEGORIES+= networking
-MASTER_SITES= ftp://ftp.ucs.ed.ac.uk/pub/videoconference/imm/
-DISTFILES= imm.src.tar.Z
-
-LIB_DEPENDS= tk\\.3\\.:${PORTSDIR}/x11/tk
-
-WRKSRC= ${WRKDIR}/src
-
-.include <bsd.port.mk>
diff --git a/mbone/imm/distinfo b/mbone/imm/distinfo
deleted file mode 100644
index c09f995b5f45..000000000000
--- a/mbone/imm/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (imm.src.tar.Z) = b260d70441f94029b4072c9a92b735ec
diff --git a/mbone/imm/files/patch-aa b/mbone/imm/files/patch-aa
deleted file mode 100644
index 3e1ea4fb9214..000000000000
--- a/mbone/imm/files/patch-aa
+++ /dev/null
@@ -1,195 +0,0 @@
-diff -rc2 src.orig/Makefile src/Makefile
-*** orig-Makefile Thu Feb 17 04:15:02 1994
---- Makefile Thu Oct 13 21:21:15 1994
-***************
-*** 1,50 ****
-- # This is a simplified Makefile for use in Tk distributions. Before using
-- # it to compile Tk, you may wish to reset some of the following variables:
- #
-! # TCL_DIR - Name of directory holding tcl.h and tcl.a.
-! # XLIB - If your Xlib library isn't in the standard place,
-! # you can replace "-lX11" with the name of the file
-! # containing your library archive.
-! # INSTALL_DIR - Full path name of top-level directory where
-! # information is installed.
-! # TK_LIBRARY - Full path name of directory to contain scripts
-! # and other library files used by Tk. This value
-! # is available to applications as the variable
-! # $tk_library. If the environment variable
-! # TK_LIBRARY is defined by a user, it will override
-! # the value specified in this Makefile.
-! # LIB_DIR - Directory in which to install the archive libtcl.a
-! # BIN_DIR - Directory in which to install executables such as imm.
-! # INCLUDE_DIR - Directory in which to install header files.
-! # MANx_DIR - Directories in which to install manual entries.
-! # RANLIB - If you're using a System-V-based UNIX that doesn't
-! # have ranlib, change this definition to "echo" or
-! # something else harmless.
-! # SHELL - Some versions of make (e.g. SGI's) use this variable
-! # to determine which shell to use for executing
-! # commands.
- #
-!
-! TCL_DIR = /usr/local/packages/tk3.6/tcl7.3
-! #TCL_DIR = /usr/local/packages/tk/tcl
-! XLIB = -lX11
-! INSTALL_DIR = /usr/local
- LIB_DIR = $(INSTALL_DIR)/lib
-! TK_LIBRARY = $(INSTALL_DIR)/lib/tk
- BIN_DIR = $(INSTALL_DIR)/bin
- INCLUDE_DIR = $(INSTALL_DIR)/include
- SHELL = /bin/sh
-- TARGET = ../solaris
--
-- # ANSI-C procedure prototypes are turned on by default if supported
-- # by the compiler. To turn them off, uncomment the following line:
--
-- # NP = -DNO_PROTOTYPE
-
-! # To compile under OpenWindows, uncomment the following line:
-!
-! OW = -I/usr/openwin/include -L/usr/openwin/lib
-! CC = cc -w
-! CFLAGS = -xO4 -dalign -DSIG_T=int -DSOLARIS -DMULTICAST -I. -I$(INCLUDE_DIR) -O -DTK_LIBRARY=\"${TK_LIB}\" ${NP} ${OW} -lnsl -lsocket
-
- ROBJS = protocol.o mcl.o xlopen.o utils.o imm_init.o
---- 1,18 ----
- #
-! # Makefile for imm under FreeBSD 2.0
- #
-!
-! TCL_DIR = /usr/local/include
-! XLIB = -L/usr/X11R6/lib -lX11
-! INSTALL_DIR = $(DESTDIR)/usr/local
- LIB_DIR = $(INSTALL_DIR)/lib
-! TK_LIBRARY = $(INSTALL_DIR)/lib/tk
- BIN_DIR = $(INSTALL_DIR)/bin
- INCLUDE_DIR = $(INSTALL_DIR)/include
- SHELL = /bin/sh
-
-! CFLAGS = -DSIG_T=void -DMULTICAST -DHAVE_UNISTD_H -I. \
-! -I$(TCL_DIR) -O -DTK_LIBRARY=\"${TK_LIBRARY}\" -I/usr/X11R6/include \
-! -DFUNCPROTO=15
-
- ROBJS = protocol.o mcl.o xlopen.o utils.o imm_init.o
-***************
-*** 52,62 ****
- SOBJS = protocol.o immserv.o sorttree.o utils.o
-
-! LIBS = /usr/local/lib/libtk.a /usr/local/lib/libtcl.a
-
-! all: $(TARGET)/imm $(TARGET)/immserv tcl2c
-
- tcl2c: tcl2c.c
-! $(CC) $(CFLAGS) tcl2c.c $(LIBS) $(XLIB) -o tcl2c
-!
- imm_init.c: tcl2c imm_def.tcl mcl.tcl Radio.tcl Listbox.tcl viewbox.tcl filebox.tcl mkHostname.tcl
- ./tcl2c Init < init.tcl > imm_init.c
---- 20,33 ----
- SOBJS = protocol.o immserv.o sorttree.o utils.o
-
-! LIBS = -L/usr/local/lib -ltk -ltcl
-
-! all: imm immserv
-!
-! install:
-! install -c -s -o bin -g bin -m 555 imm immserv /usr/local/bin
-
- tcl2c: tcl2c.c
-! $(CC) $(CFLAGS) tcl2c.c $(LIBS) $(XLIB) -lm -o tcl2c
-!
- imm_init.c: tcl2c imm_def.tcl mcl.tcl Radio.tcl Listbox.tcl viewbox.tcl filebox.tcl mkHostname.tcl
- ./tcl2c Init < init.tcl > imm_init.c
-***************
-*** 69,74 ****
- ./tcl2c HOSTBOX < mkHostname.tcl >> imm_init.c
-
-! $(TARGET)/imm: main.o $(ROBJS)
-! $(CC) $(CFLAGS) main.o $(ROBJS) $(LIBS) $(XLIB) -lm -o $(TARGET)/imm
-
- lscomp: lscomp.o protocol.o sorttree.o utils.o
---- 40,45 ----
- ./tcl2c HOSTBOX < mkHostname.tcl >> imm_init.c
-
-! imm: main.o $(ROBJS)
-! $(CC) $(CFLAGS) main.o $(ROBJS) $(LIBS) $(XLIB) -lcompat -lm -o imm
-
- lscomp: lscomp.o protocol.o sorttree.o utils.o
-***************
-*** 92,101 ****
- immserv.o: immserv.c immserv.h
-
-! $(TARGET)/immserv: $(SOBJS)
-! $(CC) $(CFLAGS) $(SOBJS) -o $(TARGET)/immserv
-!
-!
-!
-!
-!
-
---- 63,67 ----
- immserv.o: immserv.c immserv.h
-
-! immserv: $(SOBJS)
-! $(CC) $(CFLAGS) $(SOBJS) -lcompat -o immserv
-
-diff -rc2 orig-immserv.c immserv.c
-*** orig-immserv.c Fri Mar 4 19:01:13 1994
---- immserv.c Thu Oct 13 21:20:48 1994
-***************
-*** 21,24 ****
---- 21,25 ----
- ******************************************************************************/
- #define MAIN
-+ #include <stdlib.h>
- #include "protocol.h"
- #if defined(sgi) || defined (ultrix) || defined (__alpha) || defined(hpux) || defined(__NetBSD__)
-***************
-*** 1195,1199 ****
- int setackalarm() {}
- /******************************************************************************/
-! #ifndef __NetBSD__
- /* routine to put process to sleep */
- int usleep( wait)
---- 1196,1200 ----
- int setackalarm() {}
- /******************************************************************************/
-! #ifndef __FreeBSD__
- /* routine to put process to sleep */
- int usleep( wait)
-diff -rc2 orig-mcl.c mcl.c
-*** orig-mcl.c Wed Mar 9 18:51:36 1994
---- mcl.c Thu Oct 13 21:17:52 1994
-***************
-*** 23,29 ****
---- 23,36 ----
- #define MAIN
- #include "protocol.h"
-+ #ifdef __FreeBSD__
-+ #include <stdlib.h>
-+ #else
- #include <malloc.h>
-+ #endif
- #include <fcntl.h>
- #include <tk.h>
-+ #include <sys/socket.h>
-+ #include <netinet/in.h>
-+ #include <arpa/inet.h>
-
- extern int SendDeclarePacket();
-diff -rc2 orig-xlopen.c xlopen.c
-*** orig-xlopen.c Fri Mar 4 19:01:14 1994
---- xlopen.c Thu Oct 13 21:18:29 1994
-***************
-*** 30,34 ****
- extern char *optarg;
- extern int optind, opterr;
-! #ifndef __NetBSD__
- extern char *sys_errlist[];
- #endif
---- 30,34 ----
- extern char *optarg;
- extern int optind, opterr;
-! #ifndef __FreeBSD__
- extern char *sys_errlist[];
- #endif
diff --git a/mbone/imm/files/patch-ab b/mbone/imm/files/patch-ab
deleted file mode 100644
index af587ebd7abb..000000000000
--- a/mbone/imm/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
-*** main.c.orig Thu Oct 27 16:14:52 1994
---- main.c Fri Mar 31 12:34:29 1995
-***************
-*** 132,138 ****
- ClientData clientdata;
- Tcl_Interp *interp;
- int argc;
-! char *argv[];
- {
- int transmitflag = FALSE;
- int ofp;
---- 132,138 ----
- ClientData clientdata;
- Tcl_Interp *interp;
- int argc;
-! int *argv[];
- {
- int transmitflag = FALSE;
- int ofp;
diff --git a/mbone/imm/pkg-comment b/mbone/imm/pkg-comment
deleted file mode 100644
index 4c4b17146648..000000000000
--- a/mbone/imm/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-IMM - Internet Image Multicaster (and receiver)
diff --git a/mbone/imm/pkg-descr b/mbone/imm/pkg-descr
deleted file mode 100644
index 2da8c557a389..000000000000
--- a/mbone/imm/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This is IMM, a program to send and receive images using IP multicast.
-This program is currently in use on the MBONE to transmit semi-real-time
-weather satellite images, as well as a number of other miscellaneous
-pictures. IMM requires X11R6 and either `xli' or `xv' to perform the
-actual image display.
diff --git a/mbone/imm/pkg-plist b/mbone/imm/pkg-plist
deleted file mode 100644
index 5ce784ac8432..000000000000
--- a/mbone/imm/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-@cwd /usr/local
-bin/imm
-bin/immserv
diff --git a/mbone/vic/Makefile b/mbone/vic/Makefile
deleted file mode 100644
index 689d45702d8e..000000000000
--- a/mbone/vic/Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
-# New ports collection makefile for: vic
-# Version required: 2.6
-# Date created: 14 December 1994
-# Whom: wollman
-#
-# $Id: Makefile,v 1.3 1995/04/01 12:48:46 jkh Exp $
-#
-
-DISTNAME= vic-2.6
-CATEGORIES+= networking
-MASTER_SITES= ftp://ftp.ee.lbl.gov/conferencing/vic/
-DISTFILES= vicsrc-2.6.tar.Z
-
-MAINTAINER= wollman@FreeBSD.ORG
-
-LIB_DEPENDS= BLT\\.1\\.:${PORTSDIR}/x11/blt
-
-HAS_CONFIGURE= yes
-INSTALL_TARGET= MANDIR=${PREFIX}/man/manl install
-
-pre-install:
- mkdir -p ${PREFIX}/man/manl
-
-.include <bsd.port.mk>
-
diff --git a/mbone/vic/distinfo b/mbone/vic/distinfo
deleted file mode 100644
index 58c3f43fdf4b..000000000000
--- a/mbone/vic/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (vicsrc-2.6.tar.Z) = c3039479d92d3e46c6e46cc34a7f2ac0
diff --git a/mbone/vic/files/patch-aa b/mbone/vic/files/patch-aa
deleted file mode 100644
index 4cb6719c4018..000000000000
--- a/mbone/vic/files/patch-aa
+++ /dev/null
@@ -1,45 +0,0 @@
-*** Makefile.in.orig Wed Dec 14 17:08:44 1994
---- Makefile.in Wed Dec 14 17:23:38 1994
-***************
-*** 52,55 ****
---- 52,56 ----
- #have-cxx#C++ = cxx -g3
- #have-cxx#STATIC = -non_shared
-+ #have-c++#C++ = c++ -g
- #have-gcc#CC = gcc -g
- #have-gcc#C++ = g++ -g -Wall
-***************
-*** 68,71 ****
---- 69,73 ----
- TARCMD = tar cfh
- CCOPT = -O2
-+ MANDIR = /usr/man/man1
-
- #have-vpix#VPIX_DIR = /usr/src/local/vfc-1.0
-***************
-*** 132,136 ****
- #have-i386#MD_DEF = -DNOSHM
- #have-i386#TAR_PREFIX = i386
-! #have-i386#LIB_X = -L/usr/X11/lib -lXext -lX11
- #have-netbsd_sparc#TAR_PREFIX = netbsd_sparc
- #have-netbsd_sparc#TARCMD = tar -h -c -f
---- 132,137 ----
- #have-i386#MD_DEF = -DNOSHM
- #have-i386#TAR_PREFIX = i386
-! #have-i386#MD_INC = -I/usr/X11R6/include
-! #have-i386#LIB_X = -L/usr/X11R6/lib -lXext -lX11
- #have-netbsd_sparc#TAR_PREFIX = netbsd_sparc
- #have-netbsd_sparc#TARCMD = tar -h -c -f
-***************
-*** 368,372 ****
- install -c vic /usr/local/bin/vic
- install -c histtolut /usr/local/bin/histtolut
-! install -c vic.1 /usr/man/manl/vic.l
-
- clean:
---- 370,374 ----
- install -c vic /usr/local/bin/vic
- install -c histtolut /usr/local/bin/histtolut
-! install -c vic.1 $(MANDIR)/vic.l
-
- clean:
diff --git a/mbone/vic/files/patch-ab b/mbone/vic/files/patch-ab
deleted file mode 100644
index b4848016d676..000000000000
--- a/mbone/vic/files/patch-ab
+++ /dev/null
@@ -1,38 +0,0 @@
-*** configure.orig Wed Dec 14 16:28:40 1994
---- configure Wed Dec 14 17:08:40 1994
-***************
-*** 101,109 ****
- if ( -x /usr/local/bin/gcc || -x /usr/local/gcc || -x /usr/sww/bin/gcc ) set gcc='-e s/^#have-gcc#//'
- if ( -x /bin/cxx ) set cxx='-e s/^#have-cxx#//'
-! if ( -d ../blt ) set bltdir=../blt
-! if ( -d /usr/src/local/blt ) set bltdir=/usr/src/local/blt
-! if ( -d ../blt-1.7 ) set bltdir=../blt-1.7
-! if ( -d /usr/src/local/blt-1.7 ) set bltdir=/usr/src/local/blt-1.7
-! if ( -d /usr/local/src/blt-1.7 ) set bltdir=/usr/local/src/blt-1.7
- if ( ! $?bltdir ) then
- echo "configure: can't find blt (tcl/tk extension)"
---- 101,111 ----
- if ( -x /usr/local/bin/gcc || -x /usr/local/gcc || -x /usr/sww/bin/gcc ) set gcc='-e s/^#have-gcc#//'
- if ( -x /bin/cxx ) set cxx='-e s/^#have-cxx#//'
-! if ( -x /usr/bin/c++ ) set cxx='-e s/^#have-c++#//'
-! if ( -d ../blt/src ) set bltdir=../blt/src
-! if ( -d /usr/src/local/blt/src ) set bltdir=/usr/src/local/blt/src
-! if ( -d ../blt-1.7/src ) set bltdir=../blt-1.7/src
-! if ( -d /usr/src/local/blt-1.7/src ) set bltdir=/usr/src/local/blt-1.7/src
-! if ( -d /usr/local/src/blt-1.7/src ) set bltdir=/usr/local/src/blt-1.7/src
-! if ( -f /usr/local/lib/libBLT.a ) set bltdir=/usr/local/lib
- if ( ! $?bltdir ) then
- echo "configure: can't find blt (tcl/tk extension)"
-***************
-*** 140,144 ****
- set tkdir=`echo $tkdir | sed -e 's/\//\\\//'g`
- set tkinc=`echo $tkinc | sed -e 's/\//\\\//'g`
-! set bltdir=`echo $bltdir/src | sed -e 's/\//\\\//'g`
- sed $gcc $xil $rtvc $vpix $vl $svideo $cxx $dnet $irix5 $static $jv $xv \
- -e "s/@TKDIR@/$tkdir/" -e "s/@TKINC@/$tkinc/" \
---- 142,146 ----
- set tkdir=`echo $tkdir | sed -e 's/\//\\\//'g`
- set tkinc=`echo $tkinc | sed -e 's/\//\\\//'g`
-! set bltdir=`echo $bltdir | sed -e 's/\//\\\//'g`
- sed $gcc $xil $rtvc $vpix $vl $svideo $cxx $dnet $irix5 $static $jv $xv \
- -e "s/@TKDIR@/$tkdir/" -e "s/@TKINC@/$tkinc/" \
diff --git a/mbone/vic/files/patch-ac b/mbone/vic/files/patch-ac
deleted file mode 100644
index 1512d364eb77..000000000000
--- a/mbone/vic/files/patch-ac
+++ /dev/null
@@ -1,24 +0,0 @@
-*** main.cc.orig Wed Dec 14 17:11:18 1994
---- main.cc Wed Dec 14 17:12:59 1994
-***************
-*** 464,472 ****
- signal(SIGTERM, (void (*)(int ...))adios);
- #endif
-! #elif defined(__osf__) || defined(__hpux__) || defined(__NetBSD__)
- signal(SIGINT, (void (*)(int))adios);
- signal(SIGHUP, (void (*)(int))adios);
- signal(SIGTERM, (void (*)(int))adios);
-! #ifdef __NetBSD__
- signal(SIGSYS, (void (*)(int))noXShm);
- #endif
---- 464,473 ----
- signal(SIGTERM, (void (*)(int ...))adios);
- #endif
-! #elif defined(__osf__) || defined(__hpux__) || defined(__NetBSD__) || defined(__FreeBSD__)
- signal(SIGINT, (void (*)(int))adios);
- signal(SIGHUP, (void (*)(int))adios);
- signal(SIGTERM, (void (*)(int))adios);
-! #if defined(__NetBSD__) /*|| defined(__FreeBSD__)*/
-! /* XXX: -DNOSHM should not be conditionalized on just machine(i386) */
- signal(SIGSYS, (void (*)(int))noXShm);
- #endif
diff --git a/mbone/vic/pkg-comment b/mbone/vic/pkg-comment
deleted file mode 100644
index 16b01c9bc7b2..000000000000
--- a/mbone/vic/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-vic (MBONE video tool), version 2.6
diff --git a/mbone/vic/pkg-descr b/mbone/vic/pkg-descr
deleted file mode 100644
index d1168f1c3682..000000000000
--- a/mbone/vic/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This package contains the binary release of LBL's `vic' network video
-conferencing tool. This version of `vic' was compiled with MIT-SHM
-disabled, so performance will be inferior.
-
-NOTE: This kit requires XFree86 3.1, Tk, Tcl, and BLT shared libraries.
diff --git a/mbone/vic/pkg-plist b/mbone/vic/pkg-plist
deleted file mode 100644
index 18a93288dcde..000000000000
--- a/mbone/vic/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@cwd /usr/local
-bin/vic
-bin/histtolut
-man/manl/vic.l