aboutsummaryrefslogtreecommitdiff
path: root/misc/amanda32-server/files
diff options
context:
space:
mode:
Diffstat (limited to 'misc/amanda32-server/files')
-rw-r--r--misc/amanda32-server/files/extra-patch-application-src::amzfs-sendrecv.pl52
-rw-r--r--misc/amanda32-server/files/extra-patch-sendbackup-dump.c23
-rw-r--r--misc/amanda32-server/files/patch-ad14
-rw-r--r--misc/amanda32-server/files/patch-amandad-src::Makefile.in11
-rw-r--r--misc/amanda32-server/files/patch-amar-src::Makefile.in12
-rw-r--r--misc/amanda32-server/files/patch-common-src::Makefile.in11
-rw-r--r--misc/amanda32-server/files/patch-man::Makefile.in10
-rw-r--r--misc/amanda32-server/files/patch-ndmp-src::Makefile.in15
-rw-r--r--misc/amanda32-server/files/patch-perl::Amanda::Process.pm11
-rw-r--r--misc/amanda32-server/files/patch-perl::Makefile.in39
-rw-r--r--misc/amanda32-server/files/patch-perl::amglue::Makefile.in10
-rw-r--r--misc/amanda32-server/files/patch-xfer-src::Makefile.in11
-rw-r--r--misc/amanda32-server/files/pkg-deinstall.in9
-rw-r--r--misc/amanda32-server/files/pkg-install.in9
-rw-r--r--misc/amanda32-server/files/pkg-message.in3
15 files changed, 0 insertions, 240 deletions
diff --git a/misc/amanda32-server/files/extra-patch-application-src::amzfs-sendrecv.pl b/misc/amanda32-server/files/extra-patch-application-src::amzfs-sendrecv.pl
deleted file mode 100644
index 0a19153747d9..000000000000
--- a/misc/amanda32-server/files/extra-patch-application-src::amzfs-sendrecv.pl
+++ /dev/null
@@ -1,52 +0,0 @@
---- application-src/amzfs-sendrecv.pl.orig 2009-01-22 02:35:38.000000000 +0100
-+++ application-src/amzfs-sendrecv.pl 2009-01-31 10:37:59.495534563 +0100
-@@ -235,13 +235,48 @@
- } elsif (defined $errmsg) {
- $self->print_to_server_and_die($action, $errmsg, $Amanda::Script_App::ERROR);
- } else {
-- $self->print_to_server_and_die($action, "cannot estimate snapshot '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
-+ $self->print_to_server_and_die($action, "cannot estimate snapshot '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
- }
- }
-+ if ($level == 0) {
-+ my $compratio = $self->get_compratio();
-+ $msg *= int $compratio;
-+ }
-
- return $msg;
- }
-
-+sub get_compratio
-+{
-+ my $self = shift;
-+ my $action = shift;
-+
-+ my $cmd;
-+ $cmd = "$self->{pfexec_cmd} $self->{zfs_path} get -Hp -o value compressratio $self->{filesystem}\@$self->{snapshot}";
-+ debug "running (get-compression): $cmd";
-+ my($wtr, $rdr, $err, $pid);
-+ $err = Symbol::gensym;
-+ $pid = open3($wtr, $rdr, $err, $cmd);
-+ close $wtr;
-+ my ($msg) = <$rdr>;
-+ my ($errmsg) = <$err>;
-+ waitpid $pid, 0;
-+ close $rdr;
-+ close $err;
-+ if ($? != 0) {
-+ if (defined $msg && defined $errmsg) {
-+ $self->print_to_server_and_die($action, "$msg, $errmsg", $Amanda::Script_App::ERROR);
-+ } elsif (defined $msg) {
-+ $self->print_to_server_and_die($action, $msg, $Amanda::Script_App::ERROR);
-+ } elsif (defined $errmsg) {
-+ $self->print_to_server_and_die($action, $errmsg, $Amanda::Script_App::ERROR);
-+ } else {
-+ $self->print_to_server_and_die($action, "cannot read compression ratio '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
-+ }
-+ }
-+ return $msg
-+}
-+
- sub command_index_from_output {
- }
-
diff --git a/misc/amanda32-server/files/extra-patch-sendbackup-dump.c b/misc/amanda32-server/files/extra-patch-sendbackup-dump.c
deleted file mode 100644
index 3a232d1a8f25..000000000000
--- a/misc/amanda32-server/files/extra-patch-sendbackup-dump.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- client-src/sendbackup-dump.c.orig 2008-12-13 04:18:11.000000000 +0900
-+++ client-src/sendbackup-dump.c 2009-01-27 07:30:40.000000000 +0900
-@@ -35,6 +35,10 @@
- #include "clock.h"
- #include "version.h"
-
-+#ifdef __FreeBSD__
-+#include <sys/param.h>
-+#endif
-+
- #define LEAF_AND_DIRS "sed -e \'\ns/^leaf[ \t]*[0-9]*[ \t]*\\.//\nt\n/^dir[ \t]/ {\ns/^dir[ \t]*[0-9]*[ \t]*\\.//\ns%$%/%\nt\n}\nd\n\'"
-
- static amregex_t re_table[] = {
-@@ -310,6 +314,9 @@
- cmdX, config,
- "vxdump",
- dumpkeys,
-+#ifdef __FreeBSD__
-+ "64",
-+#endif
- "1048576",
- "-",
- device,
diff --git a/misc/amanda32-server/files/patch-ad b/misc/amanda32-server/files/patch-ad
deleted file mode 100644
index 3fff9c551c52..000000000000
--- a/misc/amanda32-server/files/patch-ad
+++ /dev/null
@@ -1,14 +0,0 @@
---- client-src/calcsize.c.orig 2008-01-18 09:31:16.000000000 +0900
-+++ client-src/calcsize.c 2008-08-30 20:11:59.000000000 +0900
-@@ -160,7 +160,11 @@
- dump_total += (ST_BLOCKS(finfo) + (off_t)1) / (off_t)2 + (off_t)1;
- gtar_total += ROUND(4,(ST_BLOCKS(finfo) + (off_t)1));
- }
-+#ifdef GNUTAR
-+ g_printf(" GNUTAR dump\n");
-+#else
- g_printf(" gtar dump\n");
-+#endif
- g_printf("total %-9lu %-9lu\n",gtar_total,dump_total);
- return 0;
- #else
diff --git a/misc/amanda32-server/files/patch-amandad-src::Makefile.in b/misc/amanda32-server/files/patch-amandad-src::Makefile.in
deleted file mode 100644
index 0e3a9389165b..000000000000
--- a/misc/amanda32-server/files/patch-amandad-src::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- amandad-src/Makefile.in.orig 2010-10-16 18:41:37.735202558 +0900
-+++ amandad-src/Makefile.in 2010-10-16 18:42:00.351165593 +0900
-@@ -1171,7 +1171,7 @@
- AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
- LINT = $(AMLINT)
- LINTFLAGS = $(AMLINTFLAGS)
--amlib_LTLIBRARIES = libamandad.la
-+@WANT_CLIENT_TRUE@amlib_LTLIBRARIES = libamandad.la
- libamandad_la_SOURCES = amandad_util.c
- libamandad_la_LDFLAGS = -release $(VERSION)
- libamandad_la_LIBADD = ../common-src/libamanda.la
diff --git a/misc/amanda32-server/files/patch-amar-src::Makefile.in b/misc/amanda32-server/files/patch-amar-src::Makefile.in
deleted file mode 100644
index c7941f44904e..000000000000
--- a/misc/amanda32-server/files/patch-amar-src::Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- amar-src/Makefile.in.orig 2009-01-27 14:01:04.000000000 +0900
-+++ amar-src/Makefile.in 2009-01-27 14:01:36.000000000 +0900
-@@ -856,7 +856,8 @@
- AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
- LINT = @AMLINT@
- LINTFLAGS = @AMLINTFLAGS@
--amlib_LTLIBRARIES = libamar.la
-+@WANT_SERVER_TRUE@amlib_LTLIBRARIES =
-+@WANT_CLIENT_TRUE@amlib_LTLIBRARIES = libamar.la
- libamar_la_SOURCES = amar.c
- libamar_la_LDFLAGS = -release $(VERSION)
- libamar_la_LIBADD = ../common-src/libamanda.la
diff --git a/misc/amanda32-server/files/patch-common-src::Makefile.in b/misc/amanda32-server/files/patch-common-src::Makefile.in
deleted file mode 100644
index 16be032af49a..000000000000
--- a/misc/amanda32-server/files/patch-common-src::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- common-src/Makefile.in.orig 2010-10-16 18:21:52.890010063 +0900
-+++ common-src/Makefile.in 2010-10-16 18:22:26.842453745 +0900
-@@ -1346,7 +1346,7 @@
- INCLUDES = -I$(top_srcdir)/gnulib
- AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
- AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
--amlib_LTLIBRARIES = libamanda.la
-+@WANT_CLIENT_TRUE@amlib_LTLIBRARIES = libamanda.la
- LINT = $(AMLINT)
- LINTFLAGS = $(AMLINTFLAGS)
- libamanda_la_SOURCES = alloc.c amfeatures.c amflock.c ipc-binary.c \
diff --git a/misc/amanda32-server/files/patch-man::Makefile.in b/misc/amanda32-server/files/patch-man::Makefile.in
deleted file mode 100644
index daeea0759ce8..000000000000
--- a/misc/amanda32-server/files/patch-man::Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- man/Makefile.in.orig 2009-01-22 22:51:25.000000000 +0900
-+++ man/Makefile.in 2009-01-27 07:27:10.000000000 +0900
-@@ -640,6 +640,7 @@
- amanda-auth.7 \
- amarchiver.8 \
- script-email.8
-+@WANT_SERVER_TRUE@COMMON_MAN_PAGES =
-
- CLIENT_MAN_PAGES = \
- amanda-applications.7 \
diff --git a/misc/amanda32-server/files/patch-ndmp-src::Makefile.in b/misc/amanda32-server/files/patch-ndmp-src::Makefile.in
deleted file mode 100644
index 2dd3f4b9f32d..000000000000
--- a/misc/amanda32-server/files/patch-ndmp-src::Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- ndmp-src/Makefile.in.orig 2010-10-16 18:45:40.253086014 +0900
-+++ ndmp-src/Makefile.in 2010-10-16 18:46:36.949487552 +0900
-@@ -1289,9 +1289,9 @@
- # Divide the library up into the library side and down (libndmlib.la),
- # and the full set of rules, agents, and so on required to build ndmjob
- # (libndmjob.la).
--amlib_LTLIBRARIES = \
-- libndmlib.la \
-- libndmjob.la
-+@WANT_CLIENT_TRUE@amlib_LTLIBRARIES = \
-+@WANT_CLIENT_TRUE@ libndmlib.la \
-+@WANT_CLIENT_TRUE@ libndmjob.la
-
- libndmjla = \
- ndma_comm_job.c \
diff --git a/misc/amanda32-server/files/patch-perl::Amanda::Process.pm b/misc/amanda32-server/files/patch-perl::Amanda::Process.pm
deleted file mode 100644
index 806659b3f979..000000000000
--- a/misc/amanda32-server/files/patch-perl::Amanda::Process.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- perl/Amanda/Process.pm.orig 2009-01-28 13:57:55.000000000 +0900
-+++ perl/Amanda/Process.pm 2009-01-28 13:58:19.000000000 +0900
-@@ -155,7 +155,7 @@
- $self->{ppid} = ();
- my $ps_argument = $Amanda::Constants::PS_ARGUMENT;
- if ($ps_argument eq "CYGWIN") {
-- open(PSTABLE, "-|", "ps -ef") || die("ps -ef: $!");
-+ open(PSTABLE, "-|", "ps -f") || die("ps -f: $!");
- my $psline = <PSTABLE>; #header line
- while($psline = <PSTABLE>) {
- chomp $psline;
diff --git a/misc/amanda32-server/files/patch-perl::Makefile.in b/misc/amanda32-server/files/patch-perl::Makefile.in
deleted file mode 100644
index a2bed44a04be..000000000000
--- a/misc/amanda32-server/files/patch-perl::Makefile.in
+++ /dev/null
@@ -1,39 +0,0 @@
---- perl/Makefile.in.orig 2010-10-07 03:58:28.000000000 +0900
-+++ perl/Makefile.in 2010-10-16 21:16:31.327136585 +0900
-@@ -1541,13 +1541,15 @@
- # PACKAGE: Amanda::Script_App
-
- # PACKAGE: Amanda::Script
-+@WANT_CLIENT_TRUE@am__append_xfer = Amanda/Xfer.pm
-+@WANT_CLIENT_TRUE@am__append_const = Amanda/Constants.pm
- Amanda_DATA = Amanda/Archive.pm Amanda/Process.pm $(am__append_4) \
- Amanda/Feature.pm $(am__append_6) Amanda/ClientService.pm \
-- $(am__append_7) Amanda/Xfer.pm $(am__append_10) \
-+ $(am__append_7) $(am__append_xfer) $(am__append_10) \
- $(am__append_13) Amanda/BigIntCompat.pm Amanda/Debug.pm \
- Amanda/Config.pm Amanda/Util.pm Amanda/Header.pm \
- Amanda/Tests.pm Amanda/MainLoop.pm Amanda/Paths.pm \
-- Amanda/Constants.pm Amanda/Script_App.pm $(am__append_16) \
-+ $(am__append_const) Amanda/Script_App.pm $(am__append_16) \
- $(am__append_17) Amanda/Script.pm
-
- # PACKAGE: Amanda::Archive
-@@ -1670,12 +1672,12 @@
- @WANT_SERVER_TRUE@Amanda_DB_DATA = Amanda/DB/Catalog.pm
-
- # PACKAGE: Amanda::Xfer
--libXferdir = $(amperldir)/auto/Amanda/Xfer
--libXfer_LTLIBRARIES = libXfer.la
--libXfer_la_SOURCES = Amanda/Xfer.c $(AMGLUE_SWG)
--libXfer_la_LDFLAGS = $(PERL_EXT_LDFLAGS)
--libXfer_la_LIBADD = amglue/libamglue.la \
-- $(top_builddir)/xfer-src/libamxfer.la
-+@WANT_CLIENT_TRUE@libXferdir = $(amperldir)/auto/Amanda/Xfer
-+@WANT_CLIENT_TRUE@libXfer_LTLIBRARIES = libXfer.la
-+@WANT_CLIENT_TRUE@libXfer_la_SOURCES = Amanda/Xfer.c $(AMGLUE_SWG)
-+@WANT_CLIENT_TRUE@libXfer_la_LDFLAGS = $(PERL_EXT_LDFLAGS)
-+@WANT_CLIENT_TRUE@libXfer_la_LIBADD = amglue/libamglue.la \
-+@WANT_CLIENT_TRUE@ $(top_builddir)/xfer-src/libamxfer.la
-
-
- # PACKAGE: Amanda::NDMP
diff --git a/misc/amanda32-server/files/patch-perl::amglue::Makefile.in b/misc/amanda32-server/files/patch-perl::amglue::Makefile.in
deleted file mode 100644
index 96d2bc290602..000000000000
--- a/misc/amanda32-server/files/patch-perl::amglue::Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- perl/amglue/Makefile.in 2010-10-16 19:29:45.554806332 +0900
-+++ perl/amglue/Makefile.in.orig 2010-10-07 03:58:28.000000000 +0900
-@@ -1212,6 +1212,7 @@
- list2="$$list2 $$p"; \
- else :; fi; \
- done; \
-+@WANT_CLIENT_FALSE@ list2=; \
- test -z "$$list2" || { \
- echo " $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $$list2 '$(DESTDIR)$(amlibdir)'"; \
- $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $$list2 "$(DESTDIR)$(amlibdir)"; \
diff --git a/misc/amanda32-server/files/patch-xfer-src::Makefile.in b/misc/amanda32-server/files/patch-xfer-src::Makefile.in
deleted file mode 100644
index e9c3e7838a30..000000000000
--- a/misc/amanda32-server/files/patch-xfer-src::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- xfer-src/Makefile.in.orig 2010-10-16 14:38:56.304820189 +0900
-+++ xfer-src/Makefile.in 2010-10-16 14:40:42.063983713 +0900
-@@ -1176,7 +1176,7 @@
-
- AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
- AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
--amlib_LTLIBRARIES = libamxfer.la
-+@WANT_CLIENT_TRUE@amlib_LTLIBRARIES = libamxfer.la
- LINT = $(AMLINT)
- LINTFLAGS = $(AMLINTFLAGS)
- libamxfer_la_SOURCES = \
diff --git a/misc/amanda32-server/files/pkg-deinstall.in b/misc/amanda32-server/files/pkg-deinstall.in
deleted file mode 100644
index dc962ad302fc..000000000000
--- a/misc/amanda32-server/files/pkg-deinstall.in
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-if [ "$2" != "DEINSTALL" ]; then
- exit 0
-fi
-
-%%PERL%% -i -pe "s|\" server restore client amrecover ndmp\"|\" client amrecover ndmp\"|" ${PKG_PREFIX}/%%SITE_PERL_REL%%/Amanda/Constants.pm
diff --git a/misc/amanda32-server/files/pkg-install.in b/misc/amanda32-server/files/pkg-install.in
deleted file mode 100644
index 6405b2dce989..000000000000
--- a/misc/amanda32-server/files/pkg-install.in
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-if [ "$2" != "POST-INSTALL" ]; then
- exit 0
-fi
-
-%%PERL%% -i -pe "s|\" client amrecover ndmp\"|\" server restore client amrecover ndmp\"|" ${PKG_PREFIX}/%%SITE_PERL_REL%%/Amanda/Constants.pm
diff --git a/misc/amanda32-server/files/pkg-message.in b/misc/amanda32-server/files/pkg-message.in
deleted file mode 100644
index 95ecbc36ae0f..000000000000
--- a/misc/amanda32-server/files/pkg-message.in
+++ /dev/null
@@ -1,3 +0,0 @@
-Please install these ports (they are only on-demand runtime dependencies):
- - %%PORTSDIR%%/misc/mtx if you want chg-robot changer.
- - %%PORTSDIR%%/security/aespipe if you want amcrypt(8).