aboutsummaryrefslogtreecommitdiff
path: root/misc/callid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/callid/Makefile')
-rw-r--r--misc/callid/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/misc/callid/Makefile b/misc/callid/Makefile
new file mode 100644
index 000000000000..17c28a64c915
--- /dev/null
+++ b/misc/callid/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: callid
+# Date created: 19 February 2004
+# Whom: M. Possamai
+#
+# $FreeBSD$
+#
+
+PORTNAME= callid
+PORTVERSION= 1.1
+CATEGORIES= misc
+MASTER_SITES= http://www.xs4all.nl/~possamai/callid/
+
+MAINTAINER= possamai@xs4all.nl
+COMMENT= Utility to log incoming calls using ISDN and output to mysql/php
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql40
+
+USE_MYSQL= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+NO_BUILD= yes
+
+PORTDOCS= README TODO make-db.mysql
+
+pre-everything::
+ @${ECHO} ""
+ @${ECHO} "You have to configure PHP with MYSQL support."
+ @${ECHO} ""
+ @${ECHO} "If you have already compiled PHP without MYSQL,"
+ @${ECHO} "press CTRL+C now and rebuild it before installing callid."
+ @${ECHO} ""
+
+do-install:
+ @${MKDIR} ${PREFIX}/www/callid
+ @${INSTALL_DATA} ${WRKSRC}/src/*.php ${PREFIX}/www/callid
+ @${INSTALL_DATA} ${WRKSRC}/src/*.html ${PREFIX}/www/callid
+ @${MKDIR} ${PREFIX}/www/callid/images
+ @${INSTALL_DATA} ${WRKSRC}/src/images/*.jpg ${PREFIX}/www/callid/images
+ @${INSTALL_DATA} -m 550 ${WRKSRC}/sbin/call-logd ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/rc.d/callid.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/callid.sh startup file."; \
+ ${INSTALL_SCRIPT} -m 751 ${WRKSRC}/etc/rc.d/callid.sh ${PREFIX}/etc/rc.d/callid.sh; \
+ fi
+
+.include <bsd.port.mk>