aboutsummaryrefslogtreecommitdiff
path: root/misc/gkrellm-helium/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gkrellm-helium/Makefile')
-rw-r--r--misc/gkrellm-helium/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/misc/gkrellm-helium/Makefile b/misc/gkrellm-helium/Makefile
index 471b8ca729ba..6b7100ccef8c 100644
--- a/misc/gkrellm-helium/Makefile
+++ b/misc/gkrellm-helium/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gkrellm-helium
-PORTVERSION= 2.1
-PORTREVISION= 4
+PORTVERSION= 2.3.1
CATEGORIES= misc
MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
EXTRACT_SUFX= .tgz
@@ -16,16 +15,19 @@ MAINTAINER= pav@FreeBSD.org
COMMENT= GKrellM plugin reading data from helium thermometer at Strahov, Prague
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
PLIST_FILES= libexec/gkrellm2/plugins/helium.so
USE_X_PREFIX= yes
USE_REINPLACE= yes
+CFLAGS+= -fPIC -I${LOCALBASE}/include
+MAKE_ARGS= CFLAGS="${CFLAGS}"
+
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|/usr/local/lib/gkrellm2/plugins|${PREFIX}/libexec/gkrellm2/plugins| ; \
- s|gcc -c|gcc -c -fPIC|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local/lib/gkrellm2/plugins|${PREFIX}/libexec/gkrellm2/plugins| ; \
+ s|CFLAGS =|CFLAGS?=| ; s|-lcurl|-lcurl -L${LOCALBASE}/lib|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|ulong|u_long|' ${WRKSRC}/*.c
.include <bsd.port.mk>