aboutsummaryrefslogtreecommitdiff
path: root/misc/gnome-icon-theme/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gnome-icon-theme/Makefile')
-rw-r--r--misc/gnome-icon-theme/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/misc/gnome-icon-theme/Makefile b/misc/gnome-icon-theme/Makefile
index 192ffba9510d..5746b13b958a 100644
--- a/misc/gnome-icon-theme/Makefile
+++ b/misc/gnome-icon-theme/Makefile
@@ -6,22 +6,29 @@
#
PORTNAME= gnome-icon-theme
-PORTVERSION= 1.0.9
-PORTREVISION= 1
+PORTVERSION= 1.2.0
CATEGORIES= misc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.0
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A collection of icons for the GNOME 2 desktop
+BUILD_DEPENDS= ${X11BASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+RUN_DEPENDS= ${X11BASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack gnometarget
+USE_REINPLACE= yes
+USE_GNOME= gnomehack intlhack gnometarget
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>