aboutsummaryrefslogtreecommitdiff
path: root/misc/help2man/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/help2man/Makefile')
-rw-r--r--misc/help2man/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/misc/help2man/Makefile b/misc/help2man/Makefile
index d657b9e7601a..9df4ce0f9f42 100644
--- a/misc/help2man/Makefile
+++ b/misc/help2man/Makefile
@@ -16,18 +16,26 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= arved@FreeBSD.org
COMMENT= Automatically generating simple manual pages from program output
+.if !defined(WITHOUT_NLS)
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
RUN_DEPENDS= ${BUILD_DEPENDS}
+MANLANG= "" pl fr
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
USE_PERL5= yes
MAN1= help2man.1
-MANLANG= "" pl fr
+
INFO= help2man
-PLIST_FILES= bin/help2man lib/hacklocaledir.so \
- share/locale/fr/LC_MESSAGES/help2man.mo \
- share/locale/pl/LC_MESSAGES/help2man.mo
+PLIST_FILES= bin/help2man %%NLS%%lib/hacklocaledir.so \
+ %%NLS%%share/locale/fr/LC_MESSAGES/help2man.mo \
+ %%NLS%%share/locale/pl/LC_MESSAGES/help2man.mo
.include <bsd.port.mk>