aboutsummaryrefslogtreecommitdiff
path: root/misc/txt2regex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/txt2regex/Makefile')
-rw-r--r--misc/txt2regex/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/misc/txt2regex/Makefile b/misc/txt2regex/Makefile
index 214ffffa958c..e3c6e41f7a53 100644
--- a/misc/txt2regex/Makefile
+++ b/misc/txt2regex/Makefile
@@ -16,12 +16,13 @@ MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+USE_REINPLACE= yes
NO_BUILD= yes
post-patch:
- @${PERL} -pi -e "s,/bin/bash,${LOCALBASE}/bin/bash,g ; \
+ @${REINPLACE_CMD} -e "s,/bin/bash,${LOCALBASE}/bin/bash,g ; \
s,\`seq,\`gseq,g" ${WRKSRC}/${DISTNAME}.sh
- @${PERL} -pi -e "s,/usr,${LOCALBASE},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,/usr,${LOCALBASE},g" ${WRKSRC}/Makefile
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME}.sh ${PREFIX}/bin/txt2regex