aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/tinderbox/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/misc/tinderbox/Makefile b/misc/tinderbox/Makefile
index 250e373b34bd..a6dc44d731a4 100644
--- a/misc/tinderbox/Makefile
+++ b/misc/tinderbox/Makefile
@@ -29,6 +29,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
+.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL)
+BROKEN= "Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL"
+.endif
+
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql