aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/colorls/Makefile4
-rw-r--r--misc/mmv/Makefile25
-rw-r--r--misc/mshell/Makefile10
3 files changed, 12 insertions, 27 deletions
diff --git a/misc/colorls/Makefile b/misc/colorls/Makefile
index 6c3112a7e808..f0ecb53a9b01 100644
--- a/misc/colorls/Makefile
+++ b/misc/colorls/Makefile
@@ -3,7 +3,7 @@
# Date created: 8 March 1995
# Whom: Satoshi Asami
#
-# $Id: Makefile,v 1.3 1995/04/01 12:50:06 jkh Exp $
+# $Id: Makefile,v 1.4 1995/04/15 01:28:36 asami Exp $
#
DISTNAME= colorls
@@ -20,7 +20,7 @@ FTP_SITE= ftp.freebsd.org
FTP_DIR= /pub/FreeBSD/FreeBSD-current/src/bin/
.if !defined(MASTER_SITE_OVERRIDE)
-fetch: pre-fetch
+do-fetch:
@if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
@(cd ${DISTDIR}; \
if [ ! -f ${DISTFILES} ]; then \
diff --git a/misc/mmv/Makefile b/misc/mmv/Makefile
index 7ac986a19ed5..f2bfb4b2d1b2 100644
--- a/misc/mmv/Makefile
+++ b/misc/mmv/Makefile
@@ -3,7 +3,7 @@
# Date created: 2 Feb 1995
# Whom: Michael Elbel (me)
#
-# $Id: Makefile,v 1.4 1995/04/11 02:34:03 asami Exp $
+# $Id: Makefile,v 1.5 1995/04/16 05:22:22 asami Exp $
#
@@ -17,11 +17,11 @@ MAINTAINER= me@FreeBSD.org
DISTDIR=${PORTSDIR}/distfiles/${DISTNAME}
SITE_DISTFILES= volume21/mmv/part01.Z volume21/mmv/part02.Z volume22/mmv.pch.Z
-NO_WRKSUBDIR=true
+NO_WRKSUBDIR= yes
# targets shamelessly hacked from the bsd.ports.mk file
-fetch: pre-fetch
+do-fetch:
@if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
@(cd ${DISTDIR}; \
for file in ${SITE_DISTFILES}; do \
@@ -42,11 +42,10 @@ fetch: pre-fetch
fi \
done)
-extract: fetch work/.extract_done
+pre-extract:
+ chmod +x scripts/unshar scripts/makeitapatch
-work/.extract_done:
- @${MAKE} ${.MAKEFLAGS} checksum pre-extract
- @echo "===> Extracting for ${DISTNAME}"
+do-extract:
@rm -rf ${WRKDIR}
@mkdir -p ${WRKDIR}/tmp
@(cd ${DISTDIR} ; for file in ${DISTFILES}; do \
@@ -61,17 +60,10 @@ work/.extract_done:
${SCRIPTDIR}/makeitapatch tmp/mmv.pch ; \
mv tmp/mmv.pch ${PATCHDIR}/patch-0a ; \
cat mmv.c.? >mmv.c ; rm mmv.c.? )
- ${TOUCH} ${TOUCH_FLAGS} ${EXTRACT_COOKIE}
-
-pre-extract:
- chmod +x scripts/unshar scripts/makeitapatch
-install: build work/.install_done
-work/.install_done:
- echo "===> Installing for ${DISTNAME}"
- (if [ ! -d ${PREFIX}/bin ] ; then mkdir -p ${PREFIX}/bin ; fi ; \
- cd ${PREFIX}/bin ; rm -f mmv mad mcp mln ; \
+do-install:
+ (cd ${PREFIX}/bin ; rm -f mmv mad mcp mln ; \
cd ${WRKSRC}; \
install ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
mmv ${PREFIX}/bin ; \
@@ -82,6 +74,5 @@ work/.install_done:
if [ ! -d ${PREFIX}/man/man1 ]; then mkdir -p ${PREFIX}/man/man1; fi; \
install ${COPY} -o ${BINOWN} -g ${BINGRP} \
mmv.1.gz ${PREFIX}/man/man1 ; )
- @${TOUCH} ${TOUCH_FLAGS} ${INSTALL_COOKIE}
.include <bsd.port.mk>
diff --git a/misc/mshell/Makefile b/misc/mshell/Makefile
index 2a2694a528bc..491a20b543e5 100644
--- a/misc/mshell/Makefile
+++ b/misc/mshell/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 September 1994
# Whom: jmz
#
-# $Id$
+# $Id: Makefile,v 1.5 1995/04/15 03:45:46 asami Exp $
#
DISTNAME= mshell
@@ -16,16 +16,10 @@ MAINTAINER= jmz@FreeBSD.org
NO_WRKSUBDIR= yes
-EXTRACT_COOKIE?= ${.CURDIR}/.extract_done
-
-extract: fetch pre-extract ${EXTRACT_COOKIE}
-
-${EXTRACT_COOKIE}:
- @echo "===> Extracting for ${DISTNAME}"
+do-extract:
@rm -rf ${WRKDIR}
@mkdir -p ${WRKDIR}
zcat ${DISTDIR}/${DISTFILES} |(cd ${WRKDIR}; \
awk '{if (/^#!/) x++} {if(x) print $$0'}| /bin/sh)
- @touch -f ${EXTRACT_COOKIE}
.include <bsd.port.mk>