aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/py-pytorch/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/misc/py-pytorch/Makefile b/misc/py-pytorch/Makefile
index 4c2569140696..2a7737b318fc 100644
--- a/misc/py-pytorch/Makefile
+++ b/misc/py-pytorch/Makefile
@@ -50,6 +50,15 @@ BINARY_ALIAS= make=${GMAKE}
POST_PLIST= fix-plist
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+USES+= llvm:max=15
+CC= clang${LLVM_VERSION}
+CPP= clang-cpp${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+.endif
+
post-install: # strip binaries
@${STRIP_CMD} \
${STAGEDIR}${PYTHON_SITELIBDIR}/torch/bin/torch_shm_manager \