aboutsummaryrefslogtreecommitdiff
path: root/multimedia/linux-c6-libtheora/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/linux-c6-libtheora/Makefile')
-rw-r--r--multimedia/linux-c6-libtheora/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/multimedia/linux-c6-libtheora/Makefile b/multimedia/linux-c6-libtheora/Makefile
new file mode 100644
index 000000000000..bffe9abf26fb
--- /dev/null
+++ b/multimedia/linux-c6-libtheora/Makefile
@@ -0,0 +1,27 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= libtheora
+PORTVERSION= 1.1.0
+CATEGORIES= multimedia linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Theora Video Compression Codec (Linux Fedora 10)
+
+CONFLICTS= linux-libtheora-[0-9]* linux-f10-libtheora[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+
+RPMVERSION= 2.el6
+USE_LDCONFIG= yes
+
+PLIST_FILES= usr/lib/libtheora.so.0 usr/lib/libtheora.so.0.3.9 \
+ usr/lib/libtheoradec.so.1 usr/lib/libtheoradec.so.1.1.3 \
+ usr/lib/libtheoraenc.so.1 usr/lib/libtheoraenc.so.1.1.2
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= COPYING README
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>