aboutsummaryrefslogtreecommitdiff
path: root/multimedia/linux-realplayer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/linux-realplayer/Makefile')
-rw-r--r--multimedia/linux-realplayer/Makefile151
1 files changed, 88 insertions, 63 deletions
diff --git a/multimedia/linux-realplayer/Makefile b/multimedia/linux-realplayer/Makefile
index 863b75176434..25e212b42c9f 100644
--- a/multimedia/linux-realplayer/Makefile
+++ b/multimedia/linux-realplayer/Makefile
@@ -6,95 +6,120 @@
#
PORTNAME= linux-realplayer
-PORTVERSION= 8.cs2
-PORTREVISION= 5
+PORTVERSION= 10.0.1
CATEGORIES= multimedia audio linux
-MASTER_SITES= http://docs.real.com/docs/playerpatch/unix/:update
-DISTFILES= ${MAINDIST} ${UPDATEDIST:S/$/:update/}
-EXTRACT_ONLY= ${UPDATEDIST}
+MASTER_SITES= https://helixcommunity.org/download.php/643/
+EXTRACT_SUFX= .rpm
MAINTAINER= ports@FreeBSD.org
-COMMENT= Linux RealPlayer 8.0 from RealNetworks
+COMMENT= Linux RealPlayer 10 from RealNetworks
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
-RUN_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
- ${LINUXBASE}/usr/lib/libesd.so.0:${PORTSDIR}/audio/linux-esound
+RUN_DEPENDS= \
+ ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base-8 \
+ ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
+ ${LINUXBASE}/usr/lib/libesd.so.0:${PORTSDIR}/audio/linux-esound
-MAINDIST= rp${PORTVERSION:R}_linux20_libc6_i386_${PORTVERSION:E}_rpm
-UPDATEDIST= rv9_libc6_i386_cs2.tgz
-
-RADIR= ${PREFIX}/lib/RealPlayer${PORTVERSION:R}
-WRKSRC= ${WRKDIR}/usr/lib/RealPlayer${PORTVERSION:R}
-PLUGINSDIR= ${PREFIX}/lib/netscape-linux/plugins
-RABINDIR= ${PREFIX}/bin
+WRKSRC= ${WRKDIR}/usr/local/RealPlayer
+ONLY_FOR_ARCHS= i386
+RESTRICTED= "Redistribution not allowed"
+NO_BUILD= yes
# Linux binary should not be stripped by INSTALL_PROGRAM
# because as a side effect it brands the binary as FreeBSD.
STRIP=
+RADIR= ${PREFIX}/lib/RealPlayer
+PLUGINSDIR= ${PREFIX}/lib/linux-mozilla/plugins
+RABINDIR= ${PREFIX}/bin
+
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+.else
+PLIST_SUB+= NLS=""
+.endif
+
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${MAINDIST})
-IGNORE= may not be automatically fetched due to licensing\
- restrictions. You MUST manually fetch the Linux RPM version after\
- reading and agreeing to the license at:\
- http://forms.real.com/real/player/blackjack.html \
- - once ${DISTFILES} has been downloaded, move it to\
- ${DISTDIR} and then restart this build.
+.if exists(${X11BASE}/share/icons)
+WITH_ICONS= yes
+PLIST_SUB+= ICONS=""
+.else
+PLIST_SUB+= ICONS="@comment "
.endif
-USE_REINPLACE= yes
-ONLY_FOR_ARCHS= i386
-NO_CDROM= "Redistribution not allowed"
-NO_BUILD= yes
+.if exists(${X11BASE}/share/gnome)
+WITH_GNOME= yes
+PLIST_SUB+= GNOME=""
+.else
+PLIST_SUB+= GNOME="@comment "
+.endif
-post-extract:
- cd ${WRKDIR}; rpm2cpio.pl ${DISTDIR}/${MAINDIST} | ${CPIO} -id --quiet
+.if defined(WITH_ICONS) || defined(WITH_GNOME)
+PLIST_SUB+= X11=""
+.else
+PLIST_SUB+= X11="@comment "
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ cd ${WRKDIR}; rpm2cpio.pl ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${CPIO} -id --quiet
post-patch:
- ${REINPLACE_CMD} -e \
- "s@/usr/lib@${PREFIX}/lib@" ${WRKSRC}/postinstall.sh
+ @${SED} 's|/usr/local|${PREFIX}|' \
+ < ${FILESDIR}/realplay > ${WRKSRC}/realplay
do-install:
${MKDIR} ${RADIR}
-.for f in mimeinstall.sh pluginstall.sh postinstall.sh
- ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${RADIR}
-.endfor
-.for f in realplay rpnp.so
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${RADIR}
-.endfor
-.for f in LICENSE Mailcap Mime.types README app.kdelnk audiosig.rm \
- firstrun.rm mime.kdelnk raclass.zip \
- realplay.desktop rp7.xpm rp7doc.png rp7doc.xpm rp7mini.xpm
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RADIR}
-.endfor
-.for d in Codecs Common Plugins
- ${MKDIR} ${RADIR}/${d}
- ${INSTALL_PROGRAM} ${WRKSRC}/${d}/*.so* ${RADIR}/${d}
-.endfor
- ${MKDIR} ${RADIR}/Plugins/ExtResources
- ${INSTALL_PROGRAM} ${WRKSRC}/Plugins/ExtResources/* ${RADIR}/Plugins/ExtResources/
- ${INSTALL_PROGRAM} ${WRKDIR}/rv9/codecs/drv4.so.6.0 ${RADIR}/Codecs/
- ${INSTALL_PROGRAM} ${WRKDIR}/rv9/codecs/rv40.so.6.0 ${RADIR}/Codecs/
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${WRKSRC}/README ${RADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/realplay.bin ${RADIR}
- ${LN} -sf ${RADIR}/realplay ${RABINDIR}
+.for dir in codecs common lib plugins share/default share/realplay
+ ${MKDIR} ${RADIR}/${dir}
+ ${INSTALL_DATA} ${WRKSRC}/${dir}/* ${RADIR}/${dir}
+.endfor
-.if exists(${PLUGINSDIR})
- ${LN} -sf ${RADIR}/raclass.zip ${PLUGINSDIR}
- ${LN} -sf ${RADIR}/rpnp.so ${PLUGINSDIR}
+.if !defined(WITHOUT_NLS)
+ ${MKDIR} ${RADIR}/share/locale
+ ${CP} -R ${WRKSRC}/share/locale/* ${RADIR}/share/locale
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${RADIR}/share/locale
.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/RealPlayer8
- ${INSTALL_DATA} ${WRKSRC}/Help/readme ${PREFIX}/share/doc/RealPlayer8
- ${INSTALL_DATA} ${WRKSRC}/Help/realplay.htm ${PREFIX}/share/doc/RealPlayer8
- ${MKDIR} ${PREFIX}/share/doc/RealPlayer8/realplay
- ${INSTALL_DATA} ${WRKSRC}/Help/realplay/*.htm ${PREFIX}/share/doc/RealPlayer8/realplay
- ${MKDIR} ${PREFIX}/share/doc/RealPlayer8/realplay/pics
- ${INSTALL_DATA} ${WRKSRC}/Help/realplay/pics/* ${PREFIX}/share/doc/RealPlayer8/realplay/pics
+ ${MKDIR} ${PLUGINSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/mozilla/* ${PLUGINSDIR}
+
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/realplay ${PREFIX}/bin
+
+.if defined(WITH_ICONS)
+. for size in 16x16 32x32 48x48 192x192
+ ${MKDIR} ${X11BASE}/share/icons/hicolor/${size}/apps
+ ${INSTALL_DATA} ${WRKSRC}/share/icons/realplay_${size}.png \
+ ${X11BASE}/share/icons/hicolor/${size}/apps
+. endfor
+. for size in 48x48 192x192
+ ${MKDIR} ${X11BASE}/share/icons/hicolor/${size}/mimetypes
+ ${INSTALL_DATA} ${WRKSRC}/share/icons/mime-*_${size}.png \
+ ${X11BASE}/share/icons/hicolor/${size}/mimetypes
+. endfor
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
+.if defined(WITH_GNOME)
+ ${MKDIR} ${X11BASE}/share/gnome/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/share/realplay.png ${X11BASE}/share/gnome/pixmaps
+
+ ${MKDIR} ${X11BASE}/share/gnome/applications
+ ${INSTALL_DATA} ${WRKSRC}/share/realplay.desktop \
+ ${X11BASE}/share/gnome/applications
+
+ ${MKDIR} ${X11BASE}/share/gnome/application-registry
+ ${INSTALL_DATA} ${WRKSRC}/share/realplay.applications \
+ ${X11BASE}/share/gnome/application-registry
+
+ ${MKDIR} ${X11BASE}/share/gnome/mime-info
+ ${INSTALL_DATA} ${WRKSRC}/share/realplay.keys ${WRKSRC}/share/realplay.mime \
+ ${X11BASE}/share/gnome/mime-info
+.endif
.include <bsd.port.post.mk>