aboutsummaryrefslogtreecommitdiff
path: root/net-im/gnomeicu2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/gnomeicu2/Makefile')
-rw-r--r--net-im/gnomeicu2/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/net-im/gnomeicu2/Makefile b/net-im/gnomeicu2/Makefile
index 124cd7d0d9f4..73e6c22941d2 100644
--- a/net-im/gnomeicu2/Makefile
+++ b/net-im/gnomeicu2/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= gnomeicu
-PORTVERSION= 0.93
+PORTVERSION= 0.94.1
CATEGORIES= net gnome
-MASTER_SITES= ftp://gnomeicu.gdev.net/pub/gnomeicu/ \
- ftp://ftp.vision.net.au/ftp7/linuxberg/files/gnome/com/ \
- ftp://ftp.datacomm.ch/.3/linuxberg/files/gnome/com/ \
- ftp://ftp.proxad.net/mirrors/ftp.linuxberg.com/files/gnome/com/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnomeicu
MAINTAINER= nectar@FreeBSD.org
@@ -21,8 +19,23 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+.if defined(WITH_DANTE)
+LIB_DEPENDS+= socks.1:${PORTSDIR}/net/dante
+SOCKSFLAGS= -Dconnect=Rconnect -Dbind=Rbind -Dgetsockname=Rgetsockname \
+ -Dgetpeername=Rgetpeername -Daccept=Raccept \
+ -Drresvport=Rrresvport -Dbindresvport=Rbindresvport \
+ -Dgethostbyname=Rgethostbyname \
+ -Dgethostbyname2=Rgethostbyname2 -Dsendto=Rsendto \
+ -Drecvfrom=Rrecvfrom -Drecvfrom=Rrecvfrom -Dwrite=Rwrite \
+ -Dwritev=Rwritev -Dsend=Rsend -Dsendmsg=Rsendmsg \
+ -Dread=Rread -Dreadv=Rreadv -Drecv=Rrecv -Drecvmsg=Rrecvmsg
+SOCKSLIBS= -lsocks
+.endif
+
+CONFIGURE_ARGS= --with-statusmenu
+CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="${SOCKSLIBS}" \
+ CFLAGS="${CFLAGS}"
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \