aboutsummaryrefslogtreecommitdiff
path: root/net-im/skype-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/skype-devel/Makefile')
-rw-r--r--net-im/skype-devel/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-im/skype-devel/Makefile b/net-im/skype-devel/Makefile
new file mode 100644
index 000000000000..7cd000602780
--- /dev/null
+++ b/net-im/skype-devel/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: skype
+# Date created: Jun 21. 2004
+# Whom: netchild@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= skype
+PORTVERSION= 0.90.0.3
+CATEGORIES= net
+MASTER_SITES= http://download.skype.com/linux/
+DISTNAME= skype_ver-0_90_0_3-staticQT
+
+MAINTAINER= netchild@FreeBSD.org
+COMMENT= P2P VoIP software
+
+RUN_DEPENDS=${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8 \
+ ${LINUXBASE}/usr/lib/libfreetype.so.6:${PORTSDIR}/x11-fonts/linux-fontconfig \
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
+ ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+WANT_GNOME= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgnomehier} != ""
+PLIST_SUB+= GNOME=""
+.else
+PLIST_SUB+= GNOME="@comment "
+.endif
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/skype
+
+do-install:
+ ${INSTALL} ${WRKSRC}/skype ${PREFIX}/bin/
+.if ${HAVE_GNOME:Mgnomehier} != ""
+ ${INSTALL_DATA} ${WRKSRC}/skype.desktop ${PREFIX}/share/gnome/applications/
+.endif
+ ${MKDIR} ${DATADIR}/icons
+ ${INSTALL_DATA} ${WRKSRC}/icons/* ${DATADIR}/icons/
+ ${INSTALL_DATA} ${WRKSRC}/call_in.wav ${DATADIR}/
+
+.include <bsd.port.post.mk>