aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-gabble/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-gabble/Makefile')
-rw-r--r--net-im/telepathy-gabble/Makefile40
1 files changed, 17 insertions, 23 deletions
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index 038b3f80ee36..1f0e057bb7d2 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -1,43 +1,37 @@
-# New ports collection makefile for: telepathy-gabble
-# Date created: Apr 19 2007
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-# $MCom: ports/net-im/telepathy-gabble/Makefile,v 1.10 2010/11/14 16:18:09 marcus Exp $
+# $MCom: ports/net-im/telepathy-gabble/Makefile,v 1.22 2012/08/08 16:56:40 kwm Exp $
PORTNAME= telepathy-gabble
-PORTVERSION= 0.10.4
+PORTVERSION= 0.16.1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Jabber Connection Manager for Telepathy Framework
-LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
- dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
- nice.pc:${PORTSDIR}/net-im/libnice \
- uuid.pc:${PORTSDIR}/misc/e2fsprogs-libuuid \
- telepathy-glib.pc:${PORTSDIR}/net-im/telepathy-glib \
- loudmouth-1.0.pc:${PORTSDIR}/net-im/loudmouth
-
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-
-BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
-LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
- sqlite3.8:${PORTSDIR}/databases/sqlite3
-RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
+ telepathy-glib>=0.18.0:${PORTSDIR}/net-im/telepathy-glib \
+ ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup \
+ nice:${PORTSDIR}/net-im/libnice \
+ telepathy-glib:${PORTSDIR}/net-im/telepathy-glib \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ loudmouth-1:${PORTSDIR}/net-im/loudmouth
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-Werror
LDFLAGS+= ${PTHREAD_LIBS}
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig glib20
+USE_GNOME= gnomehack glib20
+USE_SQLITE= yes
USE_OPENSSL= yes
USE_PYTHON_BUILD= yes
+CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
MAN8= telepathy-gabble.8
-.include <bsd.port.pre.mk>
+PLIST_SUB= PVERSION=${PORTVERSION}
.if defined(WITH_OPENSSL_BASE)
CONFIGURE_ENV+= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/include"
@@ -47,4 +41,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g' \
${WRKSRC}/lib/ext/wocky/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>