aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/cutegram/Makefile3
-rw-r--r--net-im/kaccounts-integration/Makefile2
-rw-r--r--net-im/kaccounts-providers/Makefile3
-rw-r--r--net-im/ktp-accounts-kcm/Makefile2
-rw-r--r--net-im/ktp-call-ui/Makefile3
-rw-r--r--net-im/ktp-common-internals/Makefile2
-rw-r--r--net-im/ktp-desktop-applets/Makefile2
-rw-r--r--net-im/ktp-text-ui/Makefile3
-rw-r--r--net-im/ricochet/Makefile4
-rw-r--r--net-im/telegramqml/Makefile4
10 files changed, 16 insertions, 12 deletions
diff --git a/net-im/cutegram/Makefile b/net-im/cutegram/Makefile
index a451a7f9afe4..e2a4f170bf3f 100644
--- a/net-im/cutegram/Makefile
+++ b/net-im/cutegram/Makefile
@@ -5,6 +5,7 @@ PORTNAME= cutegram
PORTVERSION= 2.7.1
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -stable
+PORTREVISION= 1
CATEGORIES= net-im
MAINTAINER= henry.hu.sh@gmail.com
@@ -23,7 +24,7 @@ GH_TAGNAME= 91bf14b:tools
GH_SUBDIR= Cutegram/asemantools:tools
USES= qmake:outsource desktop-file-utils qt:5 ssl
-USE_QT= qmake_build buildtools_build core qml quick sql xml multimedia \
+USE_QT= qmake_build buildtools_build core declarative sql xml multimedia \
widgets dbus webkit quickcontrols graphicaleffects sql-sqlite3
QMAKE_ARGS= LIBQTELEGRAM_INCLUDE_PATH="${LOCALBASE}/include/libqtelegram-ae" \
TELEGRAMQML_INCLUDE_PATH="${LOCALBASE}/include/telegramqml"
diff --git a/net-im/kaccounts-integration/Makefile b/net-im/kaccounts-integration/Makefile
index 1961b0612e78..dc7f1f31c59a 100644
--- a/net-im/kaccounts-integration/Makefile
+++ b/net-im/kaccounts-integration/Makefile
@@ -18,7 +18,7 @@ USES= cmake:outsource gettext pkgconfig kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons dbusaddons ecm \
i18n iconthemes kcmutils kio service wallet widgetsaddons \
akonadi
-USE_QT= dbus core gui network qml widgets xml \
+USE_QT= dbus core declarative gui network widgets xml \
buildtools_build qmake_build
OPTIONS_DEFINE= DOCS
diff --git a/net-im/kaccounts-providers/Makefile b/net-im/kaccounts-providers/Makefile
index 96165e0508ea..001b8d4e5cbf 100644
--- a/net-im/kaccounts-providers/Makefile
+++ b/net-im/kaccounts-providers/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kaccounts-providers
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -15,7 +16,7 @@ LIB_DEPENDS= libaccounts-glib.so:net-im/libaccounts-glib \
USES= cmake:outsource gettext kde:5 pkgconfig qt:5 tar:xz
USE_GNOME= intltool
USE_KDE= config coreaddons i18n kdeclarative kio package service
-USE_QT= core gui network qml xml \
+USE_QT= core declarative gui network xml \
buildtools_build qmake_build
OPTIONS_DEFINE= DOCS
diff --git a/net-im/ktp-accounts-kcm/Makefile b/net-im/ktp-accounts-kcm/Makefile
index eab8cd351dd9..e5c3e1d03b61 100644
--- a/net-im/ktp-accounts-kcm/Makefile
+++ b/net-im/ktp-accounts-kcm/Makefile
@@ -23,7 +23,7 @@ USE_GNOME= intltool
USE_KDE= auth codecs config configwidgets coreaddons ecm i18n \
iconthemes itemviews kcmutils kio notifications notifyconfig \
service texteditor wallet widgetsaddons windowsystem
-USE_QT= core dbus gui network qml sql widgets xml \
+USE_QT= core dbus declarative gui network sql widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
diff --git a/net-im/ktp-call-ui/Makefile b/net-im/ktp-call-ui/Makefile
index b24fce9d968a..3850b887d093 100644
--- a/net-im/ktp-call-ui/Makefile
+++ b/net-im/ktp-call-ui/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-call-ui
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -21,7 +22,7 @@ USE_GNOME= glib20
USE_KDE= auth codecs config configwidgets coreaddons ecm iconthemes \
i18n kcmutils kdeclarative notifications package service \
wallet widgetsaddons xmlgui
-USE_QT= core dbus gui network qml quick widgets xml \
+USE_QT= core dbus declarative gui network widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
diff --git a/net-im/ktp-common-internals/Makefile b/net-im/ktp-common-internals/Makefile
index f754ef3b4f39..a642f1532dfe 100644
--- a/net-im/ktp-common-internals/Makefile
+++ b/net-im/ktp-common-internals/Makefile
@@ -23,7 +23,7 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
kio notifications notifyconfig parts people service solid \
sonnet texteditor textwidgets wallet widgetsaddons windowsystem \
xmlgui
-USE_QT= core dbus gui network qml sql widgets xml \
+USE_QT= core dbus declarative gui network sql widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
diff --git a/net-im/ktp-desktop-applets/Makefile b/net-im/ktp-desktop-applets/Makefile
index 1c683762933e..2cba627f4daf 100644
--- a/net-im/ktp-desktop-applets/Makefile
+++ b/net-im/ktp-desktop-applets/Makefile
@@ -11,7 +11,7 @@ LIB_DEPENDS= libKTpCommonInternals.so:net-im/ktp-common-internals
USES= cmake:outsource gettext kde:5 qt:5 tar:xz
USE_KDE= ecm plasma-framework windowsystem
-USE_QT= core dbus gui network qml widgets \
+USE_QT= core dbus declarative gui network widgets \
buildtools_build qmake_build
OPTIONS_DEFINE= DOCS
diff --git a/net-im/ktp-text-ui/Makefile b/net-im/ktp-text-ui/Makefile
index 571aaabe99f6..679694805ef1 100644
--- a/net-im/ktp-text-ui/Makefile
+++ b/net-im/ktp-text-ui/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-text-ui
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -18,7 +19,7 @@ USE_KDE= archive auth codecs completion config configwidgets coreaddons \
kcmutils kdewebkit kio notifications notifyconfig people \
service sonnet textwidgets wallet widgetsaddons windowsystem \
xmlgui
-USE_QT= core dbus gui location network qml quick speech webchannel \
+USE_QT= core dbus declarative gui location network speech webchannel \
webengine widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
index 9004237101de..e95ca40aed4c 100644
--- a/net-im/ricochet/Makefile
+++ b/net-im/ricochet/Makefile
@@ -4,7 +4,7 @@
PORTNAME= ricochet
PORTVERSION= 1.1.4
DISTVERSIONPREFIX= v
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= net-im net-p2p
MAINTAINER= yuri@FreeBSD.org
@@ -20,7 +20,7 @@ LIB_DEPENDS= libprotobuf.so:devel/protobuf
USES= compiler:c++11-lib gmake pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
GH_ACCOUNT= ricochet-im
-USE_QT= core gui multimedia network qml quick quickcontrols widgets \
+USE_QT= core declarative gui multimedia network quickcontrols widgets \
buildtools_build linguisttools_build
USE_GL= gl
QMAKE_ARGS+= DEFINES+=RICOCHET_NO_PORTABLE OPENSSLDIR=${OPENSSLBASE}
diff --git a/net-im/telegramqml/Makefile b/net-im/telegramqml/Makefile
index 19cfe0a592cd..669edd7bdbe1 100644
--- a/net-im/telegramqml/Makefile
+++ b/net-im/telegramqml/Makefile
@@ -3,7 +3,7 @@
PORTNAME= telegramqml
PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= v
CATEGORIES= net-im
@@ -20,7 +20,7 @@ GH_ACCOUNT= Aseman-Land
GH_PROJECT= TelegramQML
USES= qmake:outsource qt:5 ssl
-USE_QT= qmake_build buildtools_build core qml quick sql xml multimedia
+USE_QT= qmake_build buildtools_build core declarative sql xml multimedia
USE_LDCONFIG= yes
QMAKE_ARGS= BUILD_MODE+=lib \
LIBQTELEGRAM_INCLUDE_PATH="${LOCALBASE}/include/libqtelegram-ae"