aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/hastmon
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/hastmon')
-rw-r--r--net-mgmt/hastmon/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/net-mgmt/hastmon/Makefile b/net-mgmt/hastmon/Makefile
index 2f72abecb630..e6ede4ae126a 100644
--- a/net-mgmt/hastmon/Makefile
+++ b/net-mgmt/hastmon/Makefile
@@ -13,11 +13,19 @@ LICENSE= BSD2CLAUSE
BUILD_DEPENDS= mk-configure>=0.20:devel/mk-configure
+USES= ssl
MKCMAKE?= ${LOCALBASE}/bin/mkcmake
INSTALL_TARGET= installdirs install
PORTDOCS= ChangeLog COPYRIGHT README
+post-patch:
+ ${REINPLACE_CMD} \
+ -e "s|\(-lcrypto\)|-L${OPENSSLLIB} \1|g" \
+ -e "s|\(-DHAVE_CRYPTO\)|-I${OPENSSLINC} \1|g" \
+ ${WRKSRC}/hastmon/Makefile \
+ ${WRKSRC}/hastmonctl/Makefile
+
do-build:
${SETENV} ${MKCMAKE_ENV} ${MKCMAKE} -C ${WRKSRC}