aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/vmutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/vmutils/Makefile')
-rw-r--r--net-mgmt/vmutils/Makefile37
1 files changed, 5 insertions, 32 deletions
diff --git a/net-mgmt/vmutils/Makefile b/net-mgmt/vmutils/Makefile
index 754534b5f087..ee41121132de 100644
--- a/net-mgmt/vmutils/Makefile
+++ b/net-mgmt/vmutils/Makefile
@@ -1,41 +1,12 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= vmutils
-DISTVERSIONPREFIX= v
-DISTVERSION= 1.58.0
-CATEGORIES= net-mgmt
-DISTINFO_FILE= ${.CURDIR}/../victoria-metrics/distinfo
-
-MAINTAINER= danfe@FreeBSD.org
COMMENT= Ancillary utilities and agent for VictoriaMetrics
-LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-USES= gmake go:modules,no_targets
USE_RC_SUBR= vmagent
-MAKE_ENV= PKG_TAG=${DISTVERSIONPREFIX}${DISTVERSION} \
- BUILDINFO_TAG=edd1590 GOOS=${OPSYS:tl}
-ALL_TARGET= ${PORTNAME}-pure
-
-USE_GITHUB= yes
-GH_ACCOUNT= VictoriaMetrics
-GH_PROJECT= VictoriaMetrics
-
-.include "${.CURDIR}/../victoria-metrics/Makefile.deps"
-USERS= victoria-metrics
-GROUPS= victoria-metrics
-VICTORIA_DATA?= /var/db/victoria-metrics
-
-SUB_LIST+= VICTORIA_DATA=${VICTORIA_DATA} \
- VICTORIA_USER=${USERS}
-
-PLIST_SUB+= VICTORIA_DATA=${VICTORIA_DATA} \
- VICTORIA_GROUP=${GROUPS} \
- VICTORIA_USER=${USERS}
-
-OPTIONS_DEFINE= DOCS
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
do-install:
.for p in agent alert auth backup ctl restore
@@ -47,4 +18,6 @@ do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${INSTALL_WRKSRC}/docs/vm* ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+MASTERDIR= ${.CURDIR}/../victoria-metrics
+
+.include "${MASTERDIR}/Makefile"