aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gnunet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gnunet/Makefile')
-rw-r--r--net-p2p/gnunet/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index fa97c6313885..1493af21d74c 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -33,5 +33,10 @@ MAN5= gnunet.conf.5
post-patch:
@${REINPLACE_CMD} 's|-pthread [\$$]CFLAGS|\$$CFLAGS|g ; \
s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+.for file in src/include/server/startup.h src/server/startup.c \
+ src/textui/gnunetdownload.c src/textui/insertmain.c \
+ src/textui/insertmulti.c src/util/getopt.c src/util/getopt1.c
+ @${REINPLACE_CMD} -e 's|"getopt.h"|"util/getopt.h"|g' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>