aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk14/files/patch-apps::Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk14/files/patch-apps::Makefile')
-rw-r--r--net/asterisk14/files/patch-apps::Makefile61
1 files changed, 0 insertions, 61 deletions
diff --git a/net/asterisk14/files/patch-apps::Makefile b/net/asterisk14/files/patch-apps::Makefile
deleted file mode 100644
index 44f8495864c4..000000000000
--- a/net/asterisk14/files/patch-apps::Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
---- apps/Makefile.orig Wed Jun 22 14:40:11 2005
-+++ apps/Makefile Wed Jun 22 14:43:45 2005
-@@ -40,9 +40,13 @@
- #APPS+=app_rpt.so
-
- APPS+=$(shell if [ -f /usr/include/linux/zaptel.h ]; then echo "app_zapras.so app_meetme.so app_flash.so app_zapbarge.so app_zapscan.so" ; fi)
--APPS+=$(shell if [ -f /usr/local/include/zaptel.h ]; then echo "app_zapras.so app_meetme.so app_flash.so app_zapbarge.so app_zapscan.so" ; fi)
-+APPS+=$(shell if [ -f $(LOCALBASE)/include/zaptel.h ]; then echo "app_zapras.so app_meetme.so app_flash.so app_zapbarge.so app_zapscan.so" ; fi)
- APPS+=$(shell if [ -f /usr/include/osp/osp.h ]; then echo "app_osplookup.so" ; fi)
-
-+ifdef WITH_FAX
-+APPS+=$(shell if [ -f $(LOCALBASE)/include/spandsp.h ]; then echo "app_rxfax.so app_txfax.so" ; fi)
-+endif
-+
- CFLAGS+=-fPIC
-
- ifeq ($(USE_POSTGRES_VM_INTERFACE),1)
-@@ -65,12 +69,12 @@
- $(CC) $(SOLINK) -o $@ $< -ltonezone
-
- install: all
-- for x in $(APPS); do $(INSTALL) -m 755 $$x $(DESTDIR)$(MODULES_DIR) ; done
-+ for x in $(APPS); do $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(MODULES_DIR) ; done
- rm -f $(DESTDIR)$(MODULES_DIR)/app_datetime.so
-
- app_voicemail.so : app_voicemail.o
- ifeq ($(USE_MYSQL_VM_INTERFACE),1)
-- $(CC) $(SOLINK) -o $@ $(MLFLAGS) $< -L/usr/lib/mysql -lmysqlclient -lz
-+ $(CC) $(SOLINK) -o $@ $(MLFLAGS) $< -L$(LOCALBASE)/lib/mysql -lmysqlclient -lz
- else
- ifeq ($(USE_POSTGRES_VM_INTERFACE),1)
- $(CC) $(SOLINK) -o $@ $(MLFLAGS) $< -lpq
-@@ -79,17 +83,25 @@
- endif
- endif
-
-+ifdef WITH_FAX
-+app_rxfax.so : app_rxfax.o
-+ $(CC) $(SOLINK) -o $@ $< -L$(LOCALBASE)/lib -lspandsp -ltiff
-+
-+app_txfax.so : app_txfax.o
-+ $(CC) $(SOLINK) -o $@ $< -L$(LOCALBASE)/lib -lspandsp -ltiff
-+endif
-+
- app_sql_postgres.o: app_sql_postgres.c
-- $(CC) -pipe -I/usr/local/pgsql/include $(CFLAGS) -c -o app_sql_postgres.o app_sql_postgres.c
-+ $(CC) -I$(LOCALBASE)/include/pgsql $(CFLAGS) -c -o app_sql_postgres.o app_sql_postgres.c
-
- app_sql_postgres.so: app_sql_postgres.o
-- $(CC) $(SOLINK) -o $@ $< -L/usr/local/pgsql/lib -lpq
-+ $(CC) $(SOLINK) -o $@ $< -L$(LOCALBASE)/lib -lpq
-
- app_sql_odbc.so: app_sql_odbc.o
- $(CC) $(SOLINK) -o $@ $< -lodbc
-
- look: look.c
-- $(CC) -pipe -O6 -g look.c -o look -lncurses
-+ $(CC) $(CFLAGS) look.c -o look -lncurses
-
- ifneq ($(wildcard .depend),)
- include .depend