aboutsummaryrefslogtreecommitdiff
path: root/net/avahi-app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/avahi-app/Makefile')
-rw-r--r--net/avahi-app/Makefile135
1 files changed, 135 insertions, 0 deletions
diff --git a/net/avahi-app/Makefile b/net/avahi-app/Makefile
new file mode 100644
index 000000000000..d647f23e70ad
--- /dev/null
+++ b/net/avahi-app/Makefile
@@ -0,0 +1,135 @@
+# New ports collection makefile for: avahi
+# Date created: 18 November 2005
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net/avahi-app/Makefile,v 1.6 2007/08/26 06:10:14 marcus Exp $
+#
+
+PORTNAME= avahi
+PORTVERSION= 0.6.21
+PORTREVISION?= 1
+CATEGORIES?= net dns
+MASTER_SITES= http://www.avahi.org/download/
+PKGNAMESUFFIX?= -app
+
+MAINTAINER?= gnome@FreeBSD.org
+COMMENT?= Service discovery on a local network
+
+LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2 \
+ daemon.0:${PORTSDIR}/devel/libdaemon \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ gdbm.3:${PORTSDIR}/databases/gdbm
+
+USE_GNOME?= gnomehack ltverhack glib20
+USE_GNOME_SUBR= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+AVAHI_SLAVE?= no
+CONFIGURE_ARGS?=--with-distro=freebsd \
+ --with-dbus-system-address=unix:path=/var/run/dbus/system_bus_socket \
+ --disable-monodoc \
+ --disable-doxygen-doc \
+ --disable-doxygen-dot \
+ --localstatedir=/var \
+ --enable-compat-howl
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_KQUEUE" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+.if ${AVAHI_SLAVE}=="no"
+CONFLICTS= howl-[0-9]*
+
+MAN1= avahi-browse.1 avahi-publish.1 avahi-resolve.1 avahi-set-host-name.1
+MAN5= avahi-daemon.conf.5 avahi.service.5 avahi.hosts.5
+MAN8= avahi-daemon.8 avahi-dnsconfd.8 avahi-dnsconfd.action.8
+
+MLINKS= avahi-browse.1 avahi-browse-domains.1 \
+ avahi-publish.1 avahi-publish-address.1 \
+ avahi-publish.1 avahi-publish-service.1 \
+ avahi-resolve.1 avahi-resolve-address.1 \
+ avahi-resolve.1 avahi-resolve-host-name.1
+.endif
+
+USE_RC_SUBR=yes
+
+.include <bsd.port.pre.mk>
+
+.if ${AVAHI_SLAVE}=="autoipd"
+CONFIGURE_ARGS+=--enable-autoipd
+.else
+CONFIGURE_ARGS+=--disable-autoipd
+.endif
+.if ${AVAHI_SLAVE}=="gtk"
+CONFIGURE_ARGS+=--enable-gtk
+.else
+CONFIGURE_ARGS+=--disable-gtk
+.endif
+.if ${AVAHI_SLAVE}=="libdns"
+CONFIGURE_ARGS+=--enable-compat-libdns_sd
+.else
+CONFIGURE_ARGS+=--disable-compat-libdns_sd
+.endif
+.if ${AVAHI_SLAVE}=="python"
+CONFIGURE_ARGS+=--enable-python
+.else
+CONFIGURE_ARGS+=--disable-python
+.endif
+.if ${AVAHI_SLAVE}=="qt3"
+CONFIGURE_ARGS+=--enable-qt3
+.else
+CONFIGURE_ARGS+=--disable-qt3
+.endif
+.if ${AVAHI_SLAVE}=="qt4"
+CONFIGURE_ARGS+=--enable-qt4
+.else
+CONFIGURE_ARGS+=--disable-qt4
+.endif
+.if ${AVAHI_SLAVE}=="sharp"
+CONFIGURE_ARGS+=--enable-mono
+.else
+CONFIGURE_ARGS+=--disable-mono
+.endif
+
+post-patch: avahi-post-patch
+
+avahi-post-patch:
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' \
+ ${WRKSRC}/man/*.*
+ @${RM} -f ${WRKSRC}/man/*.bak
+ @${REINPLACE_CMD} -e 's|-ldl||g ; s|netdev|network|g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/avahi-client/Makefile.in \
+ ${WRKSRC}/avahi-daemon/Makefile.in
+ @${REINPLACE_CMD} -e 's|%%RC_SUBR%%|${RC_SUBR}| ; \
+ s|%%GNOME_SUBR%%|${GNOME_SUBR}|' \
+ ${WRKSRC}/initscript/freebsd/avahi-dnsconfd.sh.in \
+ ${WRKSRC}/initscript/freebsd/avahi-daemon.sh.in
+
+post-build: avahi-post-build
+
+avahi-post-build:
+.for f in ${AVAHI_PKGCONFIG}
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${f}
+.endfor
+
+post-install: avahi-post-install
+
+avahi-post-install:
+.if ${AVAHI_SLAVE}!="no"
+.for f in ${MAN1} ${MAN2} ${MAN3} ${MAN4} ${MAN5} ${MAN6} ${MAN7} ${MAN8} ${MAN9}
+ ${INSTALL_DATA} ${WRKSRC}/man/${f} ${PREFIX}/man/man${f:E}/${f}
+.endfor
+.endif
+.for f in ${AVAHI_PKGCONFIG}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/libdata/pkgconfig
+.endfor
+.if !defined(PACKAGE_BUILDING) && (${AVAHI_SLAVE}=="no" || ${AVAHI_SLAVE}=="autoipd")
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+
+.include <bsd.port.post.mk>