aboutsummaryrefslogtreecommitdiff
path: root/net/boinc-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/boinc-client/Makefile')
-rw-r--r--net/boinc-client/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index bbea8841ed2e..73b2ae3e7c13 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -42,7 +42,8 @@ OPTIONS= X11 "Build Boinc Manager GUI" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_X11)
-CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.6-config
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
CPPFLAGS+= -I${X11BASE}/include
.else
CONFIGURE_ARGS+= --with-wx-config=false
@@ -50,7 +51,6 @@ CONFIGURE_ARGS+= --with-wx-config=false
.if !defined(WITHOUT_X11)
LIB_DEPENDS+= iconv:${PORTSDIR}/converters/libiconv \
- wx_base:${PORTSDIR}/x11-toolkits/wxgtk26 \
jpeg:${PORTSDIR}/graphics/jpeg \
glut:${PORTSDIR}/graphics/libglut
.endif