aboutsummaryrefslogtreecommitdiff
path: root/net/gnome-netstatus
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnome-netstatus')
-rw-r--r--net/gnome-netstatus/Makefile4
-rw-r--r--net/gnome-netstatus/distinfo6
-rw-r--r--net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c28
-rw-r--r--net/gnome-netstatus/pkg-plist34
4 files changed, 53 insertions, 19 deletions
diff --git a/net/gnome-netstatus/Makefile b/net/gnome-netstatus/Makefile
index 0b7b3de5c126..7f14c35a3604 100644
--- a/net/gnome-netstatus/Makefile
+++ b/net/gnome-netstatus/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/gnome-netstatus/Makefile,v 1.50 2008/09/22 23:33:17 kwm Exp $
+# $MCom: ports/net/gnome-netstatus/Makefile,v 1.52 2009/03/08 19:32:04 marcus Exp $
#
PORTNAME= gnome-netstatus
-PORTVERSION= 2.12.2
+PORTVERSION= 2.26.0
CATEGORIES= net gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/net/gnome-netstatus/distinfo b/net/gnome-netstatus/distinfo
index 72f18f1c2715..818e6650a3e8 100644
--- a/net/gnome-netstatus/distinfo
+++ b/net/gnome-netstatus/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-netstatus-2.12.2.tar.bz2) = f1f9e18b48d46adb32c9002e4325f80e
-SHA256 (gnome2/gnome-netstatus-2.12.2.tar.bz2) = 50c8b1abe1e5d813cf651bf12d1b39b00b22fadc0ee886135e5f9a08e3969943
-SIZE (gnome2/gnome-netstatus-2.12.2.tar.bz2) = 525222
+MD5 (gnome2/gnome-netstatus-2.26.0.tar.bz2) = f116157535ec185f0ea7503fafc5edd6
+SHA256 (gnome2/gnome-netstatus-2.26.0.tar.bz2) = 17169ef602037ac40e5d6b43a7add0593c9fe3f04da65aa06d70c59bc6bbccd8
+SIZE (gnome2/gnome-netstatus-2.26.0.tar.bz2) = 552061
diff --git a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
index dca19039a579..0c9c78b83b65 100644
--- a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
+++ b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
@@ -1,5 +1,5 @@
---- src/netstatus-sysdeps.c.orig 2007-02-13 04:39:19.000000000 -0500
-+++ src/netstatus-sysdeps.c 2008-04-23 13:07:24.000000000 -0400
+--- src/netstatus-sysdeps.c.orig 2009-03-08 00:25:52.000000000 -0500
++++ src/netstatus-sysdeps.c 2009-03-08 15:24:33.000000000 -0400
@@ -37,13 +37,26 @@
#ifdef __FreeBSD__
@@ -162,24 +162,24 @@
*signal_strength = 0;
+#if __FreeBSD_version < 800036
- if (g_strncasecmp (iface, "an", 2) &&
- g_strncasecmp (iface, "wi", 2) &&
- g_strncasecmp (iface, "ath", 3) &&
- g_strncasecmp (iface, "ndis", 4) &&
-+ g_strncasecmp (iface, "ural", 4) &&
-+ g_strncasecmp (iface, "ral", 3) &&
- g_strncasecmp (iface, "ipw", 3) &&
- g_strncasecmp (iface, "iwi", 3) &&
-+ g_strncasecmp (iface, "rum", 3) &&
-+ g_strncasecmp (iface, "ray", 3) &&
- g_strncasecmp (iface, "acx", 3))
+ if (g_ascii_strncasecmp (iface, "an", 2) &&
+ g_ascii_strncasecmp (iface, "wi", 2) &&
+ g_ascii_strncasecmp (iface, "ath", 3) &&
+ g_ascii_strncasecmp (iface, "ndis", 4) &&
++ g_ascii_strncasecmp (iface, "ural", 4) &&
++ g_ascii_strncasecmp (iface, "ral", 3) &&
+ g_ascii_strncasecmp (iface, "ipw", 3) &&
+ g_ascii_strncasecmp (iface, "iwi", 3) &&
++ g_ascii_strncasecmp (iface, "rum", 3) &&
++ g_ascii_strncasecmp (iface, "ray", 3) &&
+ g_ascii_strncasecmp (iface, "acx", 3))
+#else
+ if (g_strncasecmp (iface, "wlan", 4))
+#endif
return error_message;
+#if __FreeBSD_version < 700046
- if (g_strncasecmp (iface, "an", 2) == 0)
+ if (g_ascii_strncasecmp (iface, "an", 2) == 0)
{
error_message = get_an_data (iface, signal_strength);
*is_wireless = TRUE;
diff --git a/net/gnome-netstatus/pkg-plist b/net/gnome-netstatus/pkg-plist
index 9cb23623a744..b3c64e8bcbd5 100644
--- a/net/gnome-netstatus/pkg-plist
+++ b/net/gnome-netstatus/pkg-plist
@@ -32,6 +32,13 @@ share/gnome/help/gnome-netstatus/de/figures/gnome-netstatus-tx.png
share/gnome/help/gnome-netstatus/de/figures/gnome-netstatus-txrx.png
share/gnome/help/gnome-netstatus/de/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/de/legal.xml
+share/gnome/help/gnome-netstatus/el/figures/gnome-netstatus-disconn.png
+share/gnome/help/gnome-netstatus/el/figures/gnome-netstatus-error.png
+share/gnome/help/gnome-netstatus/el/figures/gnome-netstatus-idle.png
+share/gnome/help/gnome-netstatus/el/figures/gnome-netstatus-rx.png
+share/gnome/help/gnome-netstatus/el/figures/gnome-netstatus-tx.png
+share/gnome/help/gnome-netstatus/el/figures/gnome-netstatus-txrx.png
+share/gnome/help/gnome-netstatus/el/gnome-netstatus.xml
share/gnome/help/gnome-netstatus/en_GB/figures/gnome-netstatus-disconn.png
share/gnome/help/gnome-netstatus/en_GB/figures/gnome-netstatus-error.png
share/gnome/help/gnome-netstatus/en_GB/figures/gnome-netstatus-idle.png
@@ -153,6 +160,7 @@ share/omf/gnome-netstatus/gnome-netstatus-C.omf
share/omf/gnome-netstatus/gnome-netstatus-ca.omf
share/omf/gnome-netstatus/gnome-netstatus-bg.omf
share/omf/gnome-netstatus/gnome-netstatus-de.omf
+share/omf/gnome-netstatus/gnome-netstatus-el.omf
share/omf/gnome-netstatus/gnome-netstatus-en_GB.omf
share/omf/gnome-netstatus/gnome-netstatus-es.omf
share/omf/gnome-netstatus/gnome-netstatus-fr.omf
@@ -182,11 +190,13 @@ share/icons/hicolor/48x48/apps/gnome-netstatus-txrx.png
share/locale/af/LC_MESSAGES/gnome-netstatus.mo
share/locale/ar/LC_MESSAGES/gnome-netstatus.mo
share/locale/az/LC_MESSAGES/gnome-netstatus.mo
+share/locale/be@latin/LC_MESSAGES/gnome-netstatus.mo
share/locale/bg/LC_MESSAGES/gnome-netstatus.mo
share/locale/bn/LC_MESSAGES/gnome-netstatus.mo
share/locale/bn_IN/LC_MESSAGES/gnome-netstatus.mo
share/locale/bs/LC_MESSAGES/gnome-netstatus.mo
share/locale/ca/LC_MESSAGES/gnome-netstatus.mo
+share/locale/crh/LC_MESSAGES/gnome-netstatus.mo
share/locale/cs/LC_MESSAGES/gnome-netstatus.mo
share/locale/cy/LC_MESSAGES/gnome-netstatus.mo
share/locale/da/LC_MESSAGES/gnome-netstatus.mo
@@ -215,9 +225,12 @@ share/locale/it/LC_MESSAGES/gnome-netstatus.mo
share/locale/ja/LC_MESSAGES/gnome-netstatus.mo
share/locale/ka/LC_MESSAGES/gnome-netstatus.mo
share/locale/kn/LC_MESSAGES/gnome-netstatus.mo
+share/locale/ku/LC_MESSAGES/gnome-netstatus.mo
share/locale/ko/LC_MESSAGES/gnome-netstatus.mo
share/locale/lt/LC_MESSAGES/gnome-netstatus.mo
share/locale/lv/LC_MESSAGES/gnome-netstatus.mo
+share/locale/mg/LC_MESSAGES/gnome-netstatus.mo
+share/locale/ml/LC_MESSAGES/gnome-netstatus.mo
share/locale/mn/LC_MESSAGES/gnome-netstatus.mo
share/locale/mr/LC_MESSAGES/gnome-netstatus.mo
share/locale/ms/LC_MESSAGES/gnome-netstatus.mo
@@ -226,19 +239,23 @@ share/locale/ne/LC_MESSAGES/gnome-netstatus.mo
share/locale/nl/LC_MESSAGES/gnome-netstatus.mo
share/locale/nn/LC_MESSAGES/gnome-netstatus.mo
share/locale/oc/LC_MESSAGES/gnome-netstatus.mo
+share/locale/or/LC_MESSAGES/gnome-netstatus.mo
share/locale/pa/LC_MESSAGES/gnome-netstatus.mo
share/locale/pl/LC_MESSAGES/gnome-netstatus.mo
+share/locale/ps/LC_MESSAGES/gnome-netstatus.mo
share/locale/pt/LC_MESSAGES/gnome-netstatus.mo
share/locale/pt_BR/LC_MESSAGES/gnome-netstatus.mo
share/locale/ro/LC_MESSAGES/gnome-netstatus.mo
share/locale/ru/LC_MESSAGES/gnome-netstatus.mo
share/locale/rw/LC_MESSAGES/gnome-netstatus.mo
share/locale/sk/LC_MESSAGES/gnome-netstatus.mo
+share/locale/sl/LC_MESSAGES/gnome-netstatus.mo
share/locale/sq/LC_MESSAGES/gnome-netstatus.mo
share/locale/sr/LC_MESSAGES/gnome-netstatus.mo
share/locale/sr@latin/LC_MESSAGES/gnome-netstatus.mo
share/locale/sv/LC_MESSAGES/gnome-netstatus.mo
share/locale/ta/LC_MESSAGES/gnome-netstatus.mo
+share/locale/te/LC_MESSAGES/gnome-netstatus.mo
share/locale/th/LC_MESSAGES/gnome-netstatus.mo
share/locale/tr/LC_MESSAGES/gnome-netstatus.mo
share/locale/uk/LC_MESSAGES/gnome-netstatus.mo
@@ -248,6 +265,7 @@ share/locale/vi/LC_MESSAGES/gnome-netstatus.mo
share/locale/wa/LC_MESSAGES/gnome-netstatus.mo
share/locale/xh/LC_MESSAGES/gnome-netstatus.mo
share/locale/zh_CN/LC_MESSAGES/gnome-netstatus.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-netstatus.mo
share/locale/zh_TW/LC_MESSAGES/gnome-netstatus.mo
@dirrm share/omf/gnome-netstatus
@dirrm share/gnome/help/gnome-netstatus/zh_TW/figures
@@ -282,6 +300,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-netstatus.mo
@dirrm share/gnome/help/gnome-netstatus/es
@dirrm share/gnome/help/gnome-netstatus/en_GB/figures
@dirrm share/gnome/help/gnome-netstatus/en_GB
+@dirrm share/gnome/help/gnome-netstatus/el/figures
+@dirrm share/gnome/help/gnome-netstatus/el
@dirrm share/gnome/help/gnome-netstatus/de/figures
@dirrm share/gnome/help/gnome-netstatus/de
@dirrm share/gnome/help/gnome-netstatus/ca/figures
@@ -292,21 +312,35 @@ share/locale/zh_TW/LC_MESSAGES/gnome-netstatus.mo
@dirrm share/gnome/help/gnome-netstatus/C
@dirrm share/gnome/help/gnome-netstatus
@dirrm share/gnome-netstatus
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
@dirrmtry share/locale/uz@cyrillic
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
@dirrmtry share/locale/fur/LC_MESSAGES
@dirrmtry share/locale/fur
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/crh/LC_MESSAGES
+@dirrmtry share/locale/crh
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin