aboutsummaryrefslogtreecommitdiff
path: root/net/grive/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/grive/files')
-rw-r--r--net/grive/files/patch-grive_CMakeLists.txt8
-rw-r--r--net/grive/files/patch-st_ctimespec13
2 files changed, 21 insertions, 0 deletions
diff --git a/net/grive/files/patch-grive_CMakeLists.txt b/net/grive/files/patch-grive_CMakeLists.txt
new file mode 100644
index 000000000000..43ff928f2ca6
--- /dev/null
+++ b/net/grive/files/patch-grive_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- grive/CMakeLists.txt.orig 2012-07-07 23:43:18.000000000 +0800
++++ grive/CMakeLists.txt 2013-04-21 23:34:38.000000000 +0800
+@@ -27,4 +27,4 @@
+ )
+
+ install(TARGETS grive_executable RUNTIME DESTINATION bin)
+-install(FILES doc/grive.1 DESTINATION share/man/man1 )
++install(FILES doc/grive.1 DESTINATION man/man1 )
diff --git a/net/grive/files/patch-st_ctimespec b/net/grive/files/patch-st_ctimespec
new file mode 100644
index 000000000000..99c6c86927f2
--- /dev/null
+++ b/net/grive/files/patch-st_ctimespec
@@ -0,0 +1,13 @@
+diff --git libgrive/src/util/OS.cc libgrive/src/util/OS.cc
+index 0d51136..469e373 100644
+--- libgrive/src/util/OS.cc
++++ libgrive/src/util/OS.cc
+@@ -57,7 +57,7 @@ DateTime FileCTime( const std::string& filename )
+ ) ;
+ }
+
+-#if defined __APPLE__ && defined __DARWIN_64_BIT_INO_T
++#if defined(__FreeBSD__) && __FreeBSD_version < 900000
+ return DateTime( s.st_ctimespec.tv_sec, s.st_ctimespec.tv_nsec ) ;
+ #else
+ return DateTime( s.st_ctim.tv_sec, s.st_ctim.tv_nsec);