aboutsummaryrefslogtreecommitdiff
path: root/net/httpry
diff options
context:
space:
mode:
Diffstat (limited to 'net/httpry')
-rw-r--r--net/httpry/Makefile6
-rw-r--r--net/httpry/distinfo6
-rw-r--r--net/httpry/files/patch-Makefile2
3 files changed, 5 insertions, 9 deletions
diff --git a/net/httpry/Makefile b/net/httpry/Makefile
index 895c2716880b..f0c2c9f7d11f 100644
--- a/net/httpry/Makefile
+++ b/net/httpry/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= httpry
-PORTVERSION= 0.1.3
-PORTREVISION= 1
+PORTVERSION= 0.1.5
CATEGORIES= net
MASTER_SITES= http://dumpsterventures.com/jason/httpry/
@@ -34,9 +33,6 @@ RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
PLIST_SUB= EXTRASCRIPTS="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -E -e 's#^(\/etc.*)#${PREFIX}\1#' ${WRKSRC}/scripts/process_logs
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
diff --git a/net/httpry/distinfo b/net/httpry/distinfo
index c40dee798ebe..4d5bca5510d5 100644
--- a/net/httpry/distinfo
+++ b/net/httpry/distinfo
@@ -1,3 +1,3 @@
-MD5 (httpry-0.1.3.tar.gz) = 3d91e672272054e0bebd9ef9bab38a50
-SHA256 (httpry-0.1.3.tar.gz) = ca3c464a95f4b70b9b857e0df7288bdab7eaa95d0a0f26a096e0cb01fb068ea0
-SIZE (httpry-0.1.3.tar.gz) = 40720
+MD5 (httpry-0.1.5.tar.gz) = 7fbba29eaeec1fd6b25e6fa3a12be25d
+SHA256 (httpry-0.1.5.tar.gz) = 5b4a5f8170231cfbe341ad6720cadccf1c7a09b8d15c1868d3d9f803729b2560
+SIZE (httpry-0.1.5.tar.gz) = 44995
diff --git a/net/httpry/files/patch-Makefile b/net/httpry/files/patch-Makefile
index 6c1bc281aa66..09f72eb9a1cf 100644
--- a/net/httpry/files/patch-Makefile
+++ b/net/httpry/files/patch-Makefile
@@ -6,7 +6,7 @@
-CC = gcc
-CCFLAGS = -Wall -O3 -funroll-loops -I/usr/include/pcap -I/usr/local/include/pcap
-+CCFLAGS = ${CFLAGS} -I/usr/include/pcap -I/usr/local/include/pcap
++CCFLAGS = ${CFLAGS} -I/usr/include/pcap -I${LOCALBASE}/include/pcap
DEBUGFLAGS = -Wall -g -DDEBUG -I/usr/include/pcap -I/usr/local/include/pcap
LIBS = -lpcap
PROG = httpry