aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp30-server
diff options
context:
space:
mode:
Diffstat (limited to 'net/isc-dhcp30-server')
-rw-r--r--net/isc-dhcp30-server/Makefile120
-rw-r--r--net/isc-dhcp30-server/distinfo1
-rw-r--r--net/isc-dhcp30-server/files/isc-dhcpd.sh.sample33
-rw-r--r--net/isc-dhcp30-server/files/patch-freebsd47
-rw-r--r--net/isc-dhcp30-server/files/patch-site.conf35
-rw-r--r--net/isc-dhcp30-server/pkg-comment1
-rw-r--r--net/isc-dhcp30-server/pkg-descr31
-rw-r--r--net/isc-dhcp30-server/pkg-plist34
8 files changed, 0 insertions, 302 deletions
diff --git a/net/isc-dhcp30-server/Makefile b/net/isc-dhcp30-server/Makefile
deleted file mode 100644
index baccb1844ec6..000000000000
--- a/net/isc-dhcp30-server/Makefile
+++ /dev/null
@@ -1,120 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: dhcp
-# Date created: 7 Mar 1996
-# Whom: se
-#
-# $FreeBSD$
-#
-
-PORTNAME= dhcp
-PORTVERSION= 3.0.b2.24
-CATEGORIES= net
-MASTER_SITES= ftp://ftp.isc.org/isc/dhcp/
-PKGNAMEPREFIX= isc-
-PKGNAMESUFFIX= 3
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/b/:R}pl${PORTVERSION:E}
-
-MAINTAINER= clefevre@poboxes.com
-
-#
-# Global variables
-#
-
-HAS_CONFIGURE= yes
-
-MAN3= dhcpctl.3 omapi.3
-MAN5= dhclient.conf.5 dhclient.leases.5 dhcp-contrib.5 \
- dhcp-eval.5 dhcp-options.5 dhcpd.conf.5 \
- dhcpd.leases.5
-MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
-
-#
-# Local variables
-#
-
-PATCH_SUBDIRS= common minires dst omapip server client relay dhcpctl
-
-BIN_FILES= dhclient dhcpd dhcrelay
-SAMP_FILES= client/dhclient.conf server/dhcpd.conf
-RCD_FILES= isc-dhcpd.sh.sample
-DOC_FILES= CHANGES COPYRIGHT README RELNOTES
-DATA_FILES= dhclient.leases dhcpd.leases
-CONF_FILES= dhclient.conf
-
-BIN_DIR= ${PREFIX}/sbin
-ETC_DIR= ${PREFIX}/etc
-RCD_DIR= ${PREFIX}/etc/rc.d
-DOC_DIR= ${PREFIX}/share/doc/${PKGBASE}
-VARDB_DIR= /var/db
-VARRUN_DIR= /var/run
-
-STRIP?= strip
-
-#
-# Post-patch
-#
-
-post-patch: patch-scripts patch-makefile-conf patch-makefiles-dist
-
-patch-scripts:
- @${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' \
- ${WRKSRC}/client/scripts/freebsd
-
-patch-makefile-conf:
- @${PERL} -pi.fbsd -e 's|^DEBUG[ ]*=|# DEBUG ?=|g' \
- ${WRKSRC}/Makefile.conf
-
-patch-makefiles-dist:
-.for subdir in ${PATCH_SUBDIRS}
- @${PERL} -pi.fbsd -e 's|^CFLAGS[ ]*=|CFLAGS +=|g' \
- ${WRKSRC}/${subdir}/Makefile.dist
-.endfor
-
-#
-# Post-install
-#
-
-post-install: strip-binary-files install-startup-files \
- install-doc-files install-sample-files \
- create-data-files create-conf-files
-
-strip-binary-files:
-.for file in ${BIN_FILES}
-.if exists({BIN_DIR}/${file})
- @${STRIP} ${BIN_DIR}/${file}
-.endif
-.endfor
-
-install-startup-files:
-.for file in ${RCD_FILES}
- @${INSTALL_SCRIPT} ${FILESDIR}/${file} ${RCD_DIR}/${file}
-.endfor
-
-install-doc-files:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOC_DIR}
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOC_DIR}/${file}
-.endfor
-.endif
-
-install-sample-files:
-.for file in ${SAMP_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${ETC_DIR}/${file:T}.sample
-.endfor
-
-create-data-files:
-.for file in ${DATA_FILES}
-.if !exists(${VARDB_DIR}/${file})
- @${TOUCH} ${VARDB_DIR}/${file}
-.endif
-.endfor
-
-create-conf-files:
-.for file in ${CONF_FILES}
-.if !exists(${ETC_DIR}/${file})
- @${TOUCH} ${ETC_DIR}/${file}
-.endif
-.endfor
-
-.include <bsd.port.mk>
diff --git a/net/isc-dhcp30-server/distinfo b/net/isc-dhcp30-server/distinfo
deleted file mode 100644
index b4d0c5e6cbed..000000000000
--- a/net/isc-dhcp30-server/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (dhcp-3.0b2pl24.tar.gz) = ea48b791cb2be15c6d3458f5f55de8ca
diff --git a/net/isc-dhcp30-server/files/isc-dhcpd.sh.sample b/net/isc-dhcp30-server/files/isc-dhcpd.sh.sample
deleted file mode 100644
index bd9f10dbc3fd..000000000000
--- a/net/isc-dhcp30-server/files/isc-dhcpd.sh.sample
+++ /dev/null
@@ -1,33 +0,0 @@
-#! /bin/sh
-
-# $FreeBSD$
-
-OPTIONS=""
-IFACES=""
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-case "$1" in
-start)
- ${PREFIX}/sbin/dhcpd $OPTIONS $IFACES > /dev/null 2>&1
- echo -n ' dhcpd'
- ;;
-stop)
- killall dhcpd
- ;;
-restart)
- $0 stop
- $0 start
- ;;
-status)
- ps -auxww | egrep '(conserver|console)' | egrep -v "($0|egrep)"
- ;;
-*)
- echo "usage: ${0##*/} {start|stop|restart|status}" >&2
- ;;
-esac
-
-exit 0
diff --git a/net/isc-dhcp30-server/files/patch-freebsd b/net/isc-dhcp30-server/files/patch-freebsd
deleted file mode 100644
index 43c86a6aa95b..000000000000
--- a/net/isc-dhcp30-server/files/patch-freebsd
+++ /dev/null
@@ -1,47 +0,0 @@
---- client/scripts/freebsd.orig Thu Mar 22 07:59:28 2001
-+++ client/scripts/freebsd Sat Mar 24 04:50:11 2001
-@@ -16,17 +16,17 @@
- # Must be used on exit. Invokes the local dhcp client exit hooks, if any.
- exit_with_hooks() {
- exit_status=$1
-- if [ -x /etc/dhclient-exit-hooks ]; then
-- . /etc/dhclient-exit-hooks
-+ if [ -x !!PREFIX!!/etc/dhclient-exit-hooks ]; then
-+ . !!PREFIX!!/etc/dhclient-exit-hooks
- fi
- # probably should do something with exit status of the local script
- exit $exit_status
- }
-
- # Invoke the local dhcp client enter hooks, if they exist.
--if [ -x /etc/dhclient-enter-hooks ]; then
-+if [ -x !!PREFIX!!/etc/dhclient-enter-hooks ]; then
- exit_status=0
-- . /etc/dhclient-enter-hooks
-+ . !!PREFIX!!/etc/dhclient-enter-hooks
- # allow the local script to abort processing of this state
- # local script must set exit_status variable to nonzero.
- if [ $exit_status -ne 0 ]; then
-@@ -35,11 +35,11 @@
- fi
-
- if [ x$new_network_number != x ]; then
-- $LOGGER New Network Number: $new_network_number
-+ $LOGGER "New Network Number: $new_network_number"
- fi
-
- if [ x$new_broadcast_address != x ]; then
-- $LOGGER New Broadcast Address: $new_broadcast_address
-+ $LOGGER "New Broadcast Address: $new_broadcast_address"
- new_broadcast_arg="broadcast $new_broadcast_address"
- fi
- if [ x$old_broadcast_address != x ]; then
-@@ -158,7 +158,7 @@
- shift; shift
- done
- fi
-- arp -n -a | sed -n -e 's/^.*(\(.*\)) at .*$/arp -n -d \1/p' \
-+ arp -n -a | sed -n -e 's/^.*(\(.*\)) at .*$/arp -d \1/p' \
- |sh >/dev/null 2>&1
- fi
- if [ x$alias_ip_address != x ]; then
diff --git a/net/isc-dhcp30-server/files/patch-site.conf b/net/isc-dhcp30-server/files/patch-site.conf
deleted file mode 100644
index 23520fd62a97..000000000000
--- a/net/isc-dhcp30-server/files/patch-site.conf
+++ /dev/null
@@ -1,35 +0,0 @@
---- site.conf.orig Wed Jul 7 17:20:10 1999
-+++ site.conf Sat Mar 24 04:55:39 2001
-@@ -1,2 +1,32 @@
- # Put local site configuration stuff here to override the default
- # settings in Makefile.conf
-+
-+PREFIX ?= /usr/local
-+
-+BINDIR = $(PREFIX)/sbin
-+CLIENTBINDIR = $(PREFIX)/sbin
-+ADMMANDIR = $(PREFIX)/man/man8
-+ADMMANEXT = .8
-+FFMANDIR = $(PREFIX)/man/man5
-+FFMANEXT = .5
-+LIBMANDIR = $(PREFIX)/man/man3
-+LIBMANEXT = .3
-+MANCAT = man
-+# INSTALL = ${INSTALL_DATA}
-+# MANINSTALL = ${INSTALL_MAN}
-+ETC = $(PREFIX)/etc
-+LIBDIR = ${PREFIX}/lib
-+INCDIR = ${PREFIX}/include
-+
-+DEBUG ?= #none
-+
-+CFLAGS += -D_PATH_DHCPD_CONF=\"$(ETC)/dhcpd.conf\"
-+CFLAGS += -D_PATH_DHCPD_DB=\"$(VARDB)/dhcpd.leases\"
-+CFLAGS += -D_PATH_DHCPD_PID=\"$(VARRUN)/dhcpd.pid\"
-+
-+CFLAGS += -D_PATH_DHCRELAY_PID=\"$(VARRUN)/dhcrelay.pid\"
-+
-+CFLAGS += -D_PATH_DHCLIENT_CONF=\"$(ETC)/dhclient.conf\"
-+CFLAGS += -D_PATH_DHCLIENT_SCRIPT=\"$(CLIENTBINDIR)/dhclient-script\"
-+CFLAGS += -D_PATH_DHCLIENT_DB=\"$(VARDB)/dhclient.leases\"
-+CFLAGS += -D_PATH_DHCLIENT_PID=\"$(VARDB)/dhclient.pid\"
diff --git a/net/isc-dhcp30-server/pkg-comment b/net/isc-dhcp30-server/pkg-comment
deleted file mode 100644
index 77d728a4ed55..000000000000
--- a/net/isc-dhcp30-server/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-ISC Dynamic Host Configuration Protocol client and server code
diff --git a/net/isc-dhcp30-server/pkg-descr b/net/isc-dhcp30-server/pkg-descr
deleted file mode 100644
index ec2d72947025..000000000000
--- a/net/isc-dhcp30-server/pkg-descr
+++ /dev/null
@@ -1,31 +0,0 @@
-The ISC Dynamic Host Configuration Protocol Distribution provides
-a freely redistributable reference implementation of all aspects
-of the DHCP protocol, through a suite of DHCP tools:
-
- * A DHCP server
- * A DHCP client
- * A DHCP relay agent
-
-Version 3, Beta 2 of the ISC DHCP Distribution includes the following
-features that are new since version 2.0:
-
- * DHCP Failover Protocol support
- * OMAPI, an API for accessing and modifying the DHCP
- server and client state.
- * Conditional behaviour
- * Storing arbitrary information on leases
- * Address pools with access control
- * Client classing
- * Address allocation restriction by class
- * Relay agent information option support
- * Dynamic DNS updates
- * Many bug fixes, performance enhancements, and minor
- new DHCP protocol features.
-
-Also, a fully-featured implementation of dynamic DNS updates is
-included and there are no build dependencies with any BIND version.
-
-Since patch-level 15, a log-facility configuration parameter has
-been added, see the manual pages for details.
-
-WWW: http://www.isc.org/products/DHCP/
diff --git a/net/isc-dhcp30-server/pkg-plist b/net/isc-dhcp30-server/pkg-plist
deleted file mode 100644
index 9cca499d267d..000000000000
--- a/net/isc-dhcp30-server/pkg-plist
+++ /dev/null
@@ -1,34 +0,0 @@
-@comment $FreeBSD$
-etc/dhclient.conf.sample
-etc/dhcpd.conf.sample
-etc/rc.d/isc-dhcpd.sh.sample
-include/dhcpctl.h
-include/isc/boolean.h
-include/isc/dst.h
-include/isc/int.h
-include/isc/lang.h
-include/isc/list.h
-include/isc/result.h
-include/isc/types.h
-include/omapip/alloc.h
-include/omapip/buffer.h
-include/omapip/omapip.h
-lib/libdhcpctl.a
-lib/libomapi.a
-sbin/dhclient
-sbin/dhclient-script
-sbin/dhcpd
-sbin/dhcrelay
-share/doc/isc-dhcp3/CHANGES
-share/doc/isc-dhcp3/COPYRIGHT
-share/doc/isc-dhcp3/README
-share/doc/isc-dhcp3/RELNOTES
-@dirrm include/isc
-@dirrm include/omapip
-@dirrm share/doc/isc-dhcp3
-@exec [ -f /var/db/dhclient.leases ] || touch /var/db/dhclient.leases
-@unexec [ -s /var/db/dhclient.leases ] || rm -f /var/db/dhclient.leases
-@exec [ -f /var/db/dhcpd.leases ] || touch /var/db/dhcpd.leases
-@unexec [ -s /var/db/dhcpd.leases ] || rm -f /var/db/dhcpd.leases
-@exec [ -f %D/etc/dhclient.conf ] || touch %D/etc/dhclient.conf
-@unexec [ -L %D/etc/dhclient.conf -o -s %D/etc/dhclient.conf ] || rm -f %D/etc/dhclient.conf