aboutsummaryrefslogtreecommitdiff
path: root/net/kf5-kdav/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kf5-kdav/Makefile')
-rw-r--r--net/kf5-kdav/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/net/kf5-kdav/Makefile b/net/kf5-kdav/Makefile
new file mode 100644
index 000000000000..34316f5603d2
--- /dev/null
+++ b/net/kf5-kdav/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= kdav
+DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTEPOCH= 1
+CATEGORIES= net kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= DAV protocol implementation with KJobs
+
+USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
+USE_KDE= config coreaddons ecm i18n kio service
+USE_QT= concurrent core dbus gui network xml xmlpatterns \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.mk>