aboutsummaryrefslogtreecommitdiff
path: root/net/libbt
diff options
context:
space:
mode:
Diffstat (limited to 'net/libbt')
-rw-r--r--net/libbt/Makefile49
-rw-r--r--net/libbt/distinfo3
-rw-r--r--net/libbt/files/patch-include::util.h12
-rw-r--r--net/libbt/files/patch-src::peer.c14
-rw-r--r--net/libbt/pkg-descr6
-rw-r--r--net/libbt/pkg-plist18
6 files changed, 0 insertions, 102 deletions
diff --git a/net/libbt/Makefile b/net/libbt/Makefile
deleted file mode 100644
index e97dc83d00af..000000000000
--- a/net/libbt/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-# New ports collection makefile for: libbt
-# Date created: Feb 26 2004
-# Whom: Florent Thoumie <flz@xbsd.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libbt
-PORTVERSION= 1.04
-CATEGORIES= net devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= flz@FreeBSD.org
-COMMENT= C library implementing the core BitTorrent protocol
-
-LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
-
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_REINPLACE= yes
-USE_GCC= 3.4
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-
-PORTDOCS= protocol-ext.txt protocol.txt
-
-post-patch:
- @${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|\(CFLAGS:=\)|\1\@CFLAGS\@ \@CPPFLAGS\@ |' ${WRKSRC}/src/Makefile.in
-
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/src/libbt.a ${PREFIX}/lib
- ${MKDIR} ${PREFIX}/include/libbt
-.for i in btcheck btget btlist
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${i} ${PREFIX}/bin
-.endfor
-.for i in benc.h bitset.h bterror.h btmessage.h bts.h context.h peer.h random.h segmenter.h strbuf.h stream.h types.h util.h
- ${INSTALL_DATA} ${WRKSRC}/include/${i} ${PREFIX}/include/libbt
-.endfor
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_MAN} ${WRKSRC}/docs/${i} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/net/libbt/distinfo b/net/libbt/distinfo
deleted file mode 100644
index 5c6b02228e8a..000000000000
--- a/net/libbt/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (libbt-1.04.tar.gz) = c5f50f1b3d76722a6494a0ae4720b9d1
-SHA256 (libbt-1.04.tar.gz) = b769ea33c7006b2239376457c2892a5d6cc5045ca9e14f0b31333eaf7d032c9a
-SIZE (libbt-1.04.tar.gz) = 309186
diff --git a/net/libbt/files/patch-include::util.h b/net/libbt/files/patch-include::util.h
deleted file mode 100644
index 8ad3b431dd7b..000000000000
--- a/net/libbt/files/patch-include::util.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- include/util.h Fri Apr 16 08:41:48 2004
-+++ include/util.h.new Sun May 30 14:17:54 2004
-@@ -28,9 +28,4 @@
- typedef void (*exitfn_ptr) (int,void*);
- int on_exit( exitfn_ptr exitfn, void* data) ;
- #endif
--#define malloc(s) use_btmalloc_instead
--#define calloc(n,s) use_btcalloc_instead
--#define realloc(p,s) use_btrealloc_instead
--#define free(p) use_btfree_instead
--
- #endif
diff --git a/net/libbt/files/patch-src::peer.c b/net/libbt/files/patch-src::peer.c
deleted file mode 100644
index 6c2104deda6c..000000000000
--- a/net/libbt/files/patch-src::peer.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/peer.c Wed Apr 7 06:14:44 2004
-+++ src/peer.c.new Tue Apr 13 19:29:01 2004
-@@ -20,6 +20,11 @@
- # endif
- #endif
- #include <sys/types.h>
-+#if __FreeBSD__ >= 5
-+#include <sys/limits.h>
-+#else
-+#include <machine/limits.h>
-+#endif
- #include <string.h>
- #ifdef HAVE_STRINGS_H
- # include <strings.h>
diff --git a/net/libbt/pkg-descr b/net/libbt/pkg-descr
deleted file mode 100644
index 28aab005d572..000000000000
--- a/net/libbt/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-LIBBT is a C library implementing the core BitTorrent protocol.
-
-WWW: http://libbt.sourceforge.net/
-
-- Florent Thoumie
-flz@xbsd.org
diff --git a/net/libbt/pkg-plist b/net/libbt/pkg-plist
deleted file mode 100644
index 2ed1ce96441e..000000000000
--- a/net/libbt/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-bin/btcheck
-bin/btget
-bin/btlist
-include/libbt/benc.h
-include/libbt/bitset.h
-include/libbt/bterror.h
-include/libbt/btmessage.h
-include/libbt/bts.h
-include/libbt/context.h
-include/libbt/peer.h
-include/libbt/random.h
-include/libbt/segmenter.h
-include/libbt/strbuf.h
-include/libbt/stream.h
-include/libbt/types.h
-include/libbt/util.h
-lib/libbt.a
-@dirrm include/libbt