aboutsummaryrefslogtreecommitdiff
path: root/net/mediatomb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mediatomb/Makefile')
-rw-r--r--net/mediatomb/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/net/mediatomb/Makefile b/net/mediatomb/Makefile
index cb49b89aaff6..a0d63f5736b5 100644
--- a/net/mediatomb/Makefile
+++ b/net/mediatomb/Makefile
@@ -69,7 +69,7 @@ LIBEXTRACTOR_DESC= libextractor support
CONFIGURE_ARGS+= --enable-sqlite3 \
--with-sqlite3-h="${LOCALBASE}/include" \
--with-sqlite3-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
.else
CONFIGURE_ARGS+= --disable-sqlite3
.endif
@@ -86,7 +86,7 @@ CONFIGURE_ARGS+= --disable-mysql
CONFIGURE_ARGS+= --enable-libjs \
--with-js-h="${LOCALBASE}/include" \
--with-js-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= js:${PORTSDIR}/lang/spidermonkey17
+LIB_DEPENDS+= libjs.so:${PORTSDIR}/lang/spidermonkey17
.else
CONFIGURE_ARGS+= --disable-libjs
.endif
@@ -95,7 +95,7 @@ CONFIGURE_ARGS+= --disable-libjs
CONFIGURE_ARGS+= --enable-libexif \
--with-libexif-h="${LOCALBASE}/include" \
--with-libexif-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
+LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif
.else
CONFIGURE_ARGS+= --disable-libexif
.endif
@@ -110,7 +110,7 @@ CONFIGURE_ARGS+= --disable-external-transcoding
CONFIGURE_ARGS+= --enable-ffmpegthumbnailer \
--with-ffmpegthumbnailer-h="${LOCALBASE}/include" \
--with-ffmpegthumbnailer-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= ffmpegthumbnailer:${PORTSDIR}/multimedia/ffmpegthumbnailer
+LIB_DEPENDS+= libffmpegthumbnailer.so:${PORTSDIR}/multimedia/ffmpegthumbnailer
.else
CONFIGURE_ARGS+= --disable-ffmpegthumbnailer
.endif
@@ -119,14 +119,14 @@ CONFIGURE_ARGS+= --disable-ffmpegthumbnailer
.if ${PORT_OPTIONS:MCURL} && ${PORT_OPTIONS:MEXTERNAL_TRANSCODING}
CONFIGURE_ARGS+= --enable-curl \
--with-curl-cfg="${LOCALBASE}/bin/curl-config"
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
.else
CONFIGURE_ARGS+= --disable-curl
.endif
.if ${PORT_OPTIONS:MFFMPEG}
CONFIGURE_ARGS+= --enable-ffmpeg
-LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
.else
CONFIGURE_ARGS+= --disable-ffmpeg
.endif
@@ -135,7 +135,7 @@ CONFIGURE_ARGS+= --disable-ffmpeg
CONFIGURE_ARGS+= --enable-libextractor \
--with-extractor-h="${LOCALBASE}/include" \
--with-extractor-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= extractor:${PORTSDIR}/textproc/libextractor
+LIB_DEPENDS+= libextractor.so:${PORTSDIR}/textproc/libextractor
.else
CONFIGURE_ARGS+= --disable-libextractor
.endif
@@ -144,7 +144,7 @@ CONFIGURE_ARGS+= --disable-libextractor
CONFIGURE_ARGS+= --enable-id3lib \
--with-id3lib-h="${LOCALBASE}/include" \
--with-id3lib-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= id3:${PORTSDIR}/audio/id3lib
+LIB_DEPENDS+= libid3.so:${PORTSDIR}/audio/id3lib
.else
CONFIGURE_ARGS+= --disable-id3lib
.endif
@@ -152,7 +152,7 @@ CONFIGURE_ARGS+= --disable-id3lib
.if ${PORT_OPTIONS:MTAGLIB}
CONFIGURE_ARGS+= --enable-taglib \
--with-taglib-cfg="${LOCALBASE}/bin/taglib-config"
-LIB_DEPENDS+= tag:${PORTSDIR}/audio/taglib
+LIB_DEPENDS+= libtag.so:${PORTSDIR}/audio/taglib
.else
CONFIGURE_ARGS+= --disable-taglib
.endif