aboutsummaryrefslogtreecommitdiff
path: root/net/netams/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/netams/files/patch-Makefile')
-rw-r--r--net/netams/files/patch-Makefile55
1 files changed, 0 insertions, 55 deletions
diff --git a/net/netams/files/patch-Makefile b/net/netams/files/patch-Makefile
deleted file mode 100644
index eaf83cd7b7bf..000000000000
--- a/net/netams/files/patch-Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
---- Makefile.orig Wed Dec 31 11:43:37 2003
-+++ Makefile Mon Jan 5 17:16:41 2004
-@@ -10,11 +10,11 @@
- # $NetAMS: netams/Makefile,v 1.25.2.4 2003/12/31 08:43:37 jura Exp $
- ##########################################################################
- # for FreeBSD, uncomment this
--DEFINE = -DFREEBSD -D_THREAD_SAFE
--LIB = -lpcap -lcrypt
-+DEFINE += -DFREEBSD
-+LIB += -lpcap -lcrypt
- #
- # For FreeBSD-4.x uncomment this
--LIB += -pthread
-+# LIB += -pthread
- # For FreeBSD-5.x uncomment this
- # LIB += -lc_r
- #
-@@ -22,8 +22,8 @@
- # DEFINE+= -DUSE_HASH
- #
- # MySQL storage support
--DEFINE += -DUSE_MYSQL
--LIB += -lmysqlclient -L/usr/local/lib/mysql
-+# DEFINE += -DUSE_MYSQL
-+# LIB += -lmysqlclient -L/usr/local/lib/mysql
- #
- # PostgreSQL storage support
- # DEFINE += -DUSE_POSTGRES
-@@ -53,14 +53,14 @@
- # DEFINE += -DIPTBL_NONE
- ##########################################################################
- # Define here a PATH variables
--PATH_TO_CONFIG="/usr/local/etc/netams.cfg"
-+PATH_TO_CONFIG="${PREFIX}/etc/netams.conf"
- PATH_TO_LOG="/var/log/netams.log"
- #
- # Uncomment this if you want to log dropped packets
- # DEFINE += -DLOG_DROP
- # Uncomment this if you want to enable debug features
--DEFINE += -DDEBUG
--FLAGS += -g -Wall
-+# DEFINE += -DDEBUG
-+# FLAGS += -g -Wall
- # Uncomment this if you want to enable profiler support
- # LIB += -lm -pg
- # FLAGS += -pg
-@@ -81,7 +81,7 @@
- flowmodule.h versions.sh versions_build.dat
-
- CC = g++
--INCLUDE=/usr/local/include
-+INCLUDE = ${LOCALBASE}/include
- OBJ = $(SRC:.c=.o)
- CFLAGS = $(FLAGS) -I$(INCLUDE) $(DEFINE)
-